Support for vertex color import

I wanted to import my scanned objects into nomad but unfortunately it does not import the vertex colors.

Any chance this is on your to-do list?
Especially now with the iPhone being able to scan objects and directly share them to nomad is great.

1 Like

All depends which app you’re creating your scans in.
For example, I use the HEGES app and it exports GLB / STL or PLY format - only the PLY has vertex colour.
I export to PLY, bring into Meshlab (free PC app) and convert to OBJ with MTL.
Zip the OBJ & MTL together and import directly into Nomad. Done.

You basically need to find a method of getting your file into a vertex coloured format, saveable in OBJ / GLB / GLTF format for import into Nomad. If the scan creates a textured mesh then you need to use Meshlab again in order to densify a copy of your mesh and reproject the low poly texture onto the high poly mesh as vertex colour. Sounds complicated but Meshlab does a fantastic job and the end product in Nomad is really nice. Example attached

Interesting, thanks for the explanation.
Will try it out right away

So I did convert the texture to vertex colors and zip the obj and the material but still no success.

I did the conversion in zbrush which is extremely simple. I double checked and the mesh definitely has vertex colors.

Could you send me the file?

Note that I ignore the MTL file, which only stores object-level colors (but that’s not vertex color).

Yeah that was the dubious thing I was wondering with the material.
My apologies, I had show painting off from the previous session. It works!

1 Like
stephomi
November 9

hey Steph,

Any chance the lights are bugged?
Take a look at the screenshot below!
As soon as I turn on the second light the scene casts a weird shadow. It seems to be the shadow because if I turn of shadows the issue disappears.



Sorry for the dirty screenshots

It looks like your light in the back is completely parallel to the ground and therefore the shadow on your rat seems logical but since your rays of light are parallel to the ground (well I think saw the arrow on the second image) and therefore you have no shade on the ground.

Yes I think it’s getting fixed for 1.65, released soon.

If I recall, disabling/enabling ssr/ao/dof can fix the issue temporarily.