Scan code mapping issue

(I tracked this down a bit more so I think it’s worth opening a bug report now…)

There’s a bug when there are more than 2 bindings with unrecognized keys (Scan_XXX)

For example:

  • Smooth → Scan_313
  • Mask → Scan_319
  • Gizmo → Scan_386

After a restart, I can only use the initial key I press of these 3 bindings. The other keys trigger ALL the remaining keys at once.


  • Afer a restart, I press the key for Smooth. This works, but when I press the Mask hotkey after, both Mask and Gizmo are triggered at the same time and the behavior stays like that.


  • After a restart, I press the key for Mask: This works, but when I press Gizmo, both Gizmo and Smooth are triggered at the same time.

I hope I could make myself clear, let me know if I can provided additional data.


Here’s a screen capture of the bug

Sorry for being such a bother, but I’m sooo excited about using Nomad with the Tabmate!

I think I found the issue, the culprit seems to be the gesture menu itself.
Try to trigger all the scan key before opening the gesture menu, it should work.

I tried without opening the menu, it works for the first key I press, but the rest of them still come in all at the same time.

Hmm are you sure you pressed all of them just after opening Nomad?

The moment you open the gesture menu the bug will appear.
Also any other key pressed (that is not a raw scancode) will trigger the bug.

Marking the topic as solved as I’m confident I found the bug, will be fixed for 1.69.

I tried pressing all scan keys (individually) before opening the menu, but still the issue comes up:

Maybe it’s related to the gesture menu issue and is fixed by it. Thanks for looking into it!

Scancodes are working flawlessly already version 1.68. Thanks again :clap:. Tabmate is a great companion to Nomad, makes the sculpting process even more fluid.