Just a bolt

I follow tutorials on Onshape because think that combined with Nomad you can have very clean technical and hard surface results this way. So basically after importing my Gltf from onshape (with the save trick - quit and come back to let the vertices be welded) I applied a remesh voxel high enough not to lose the cleanliness of the created object.

3 Likes

I could add the “weld vertex” thing when doing a Simple merge but I don’t know if it’s something we always want.

For example I do it after a Trim operation, but not for the Simple Merge.

1 Like

For me it would be useful and less restrictive than saving, leaving and coming back. A simple box to check during the simple merge would be nice.
Thanks in advance if you know how to add it

PS : Attention, I just tried a trim after a simple merge without having done the technique to weld the vertices, it makes Nomad crash.

Do you have a way to reproduce the crash?

I tried with your mesh after the Simple Merge and the first trim do takes a long time (few seconds on my iPad), but it works correctly.

The “weld vertices” happens * after * the Trim operation. So it’s not perfect.

Edit: I’ll simply activate the “weld vertices” to the Simple Merge. Back then I didn’t do it because I didn’t considered the “load multiple external part and merge them” scenario.
For now I don’t want add a checkbox next to it so I’ll probably simply respect the “Keep topology at import” option (that I could rename “Topology cleaning” maybe).

1 Like

Ok, I tried again and in fact it does not freeze but it took 70 seconds to cut a small piece of my bolt and above all the result was chaotic with reversed faces of the missing parts … etc.

But you must not activate the weld vertices by default, please do not. We all use the simple merge (and I’m sure of it) as an object grouping in a scene so automatically the vertices are welded together we will have more control. It is better to check a box for the weld vertices so that we have the choice. thank you

Buy an iPad.

1 Like

I have iPad Pro 12.9 2018 lol

70 seconds seems a lot, it’s not what I had on my iPad Air 3.
I took the same mesh as yours and I got ~10s by trimming a small part.

The reason why it’s lagging so much is because Trim needs to fill all the holes (and since the vertices are not weld, there’s a lot of weird things considered as holes).
To make it worse if “screen space boolean” (trim settings) is checked, the whole are filled in a special manners, that fails miserably if the hole are not aligned with the camera (in a nutshell the filling only works correctly for the hole created by the Trim itself).

Anyway, this is just one of the many reason why Nomad merge vertices.

I disagree, it should and will be activated by default.
There’s no threshold when detecting duplicated vertices, the vertex needs to be strictly equal.
It normally cannot happen inside Nomad.

1 Like