Jaggy lines when use Alphas

Hi all. I’m following this tutorial for hard surface. He suggest to use alphas to easily add details to the surface, and I find it very convenient, but mine has pixelated borders no matter what.


The tutorial poly count are around 740k scene vertices but he still got smoother results than mine. (check down for more images, I can’t upload more than one).
I can have decent details just around 1.5 mil polycount. I think there are too much to sustain in multiple objects in a complete project.
If I add details, then voxel remesh down, I got orrible results. I can decimate but I’ll lost wire, then add details in the future will be pain.
I turned on “smooth shading”, that fixed a bit. But I wonder, is that just a visual smoothing or it really modify the mesh for a cleaner result ?
I found out that jaggies lines appear more when the alpha is not aliened with the grid.
Blurring the alpha a little helps, but not fix.

Any tips to improve the situation?

(I already asked to the author and he suggested some of the mentioned fix, but I’m not satisfied with the result, and I thought that asking to the community would be fine. I don’t want to depreciate the tutorial than, beside of that I found very helpful)

The tutorial working poly count

Ugly lines in my attempts

Clean lines in his screen.

Clean lines in the tutorial

I guess this is @Razuminc part to answer your question. :vulcan_salute:

1 Like

Maybe the alpha you’re using, is not “clear” or blurring out at the lines?

No, the alpha is 2000 px wide, and has super sharp lines. Blur it a little helps prevents diagonal jaggier lines, but still won’t come out good.

As knacki mentioned, @Razuminc should be able to help. It’s his tutorial so you should contact him. Maybe he has Dynamis Topology enabled or something?

We already spoke privately, but unfortunately following his tips I can’t get a good result. Therefore I decided to ask to the community, maybe somebody else has a similar problem.

My intention is not criticize Razum tutorial, just ask for a third opinion about the problem. If this result not appropriate I can remove the thread.

I would think you would have to use Dynamic Topology or increase your mesh resolution (higher poly count). Other that that, I’m not sure.

You could try blurring the mask a little but not sure it would be as “hard surface”.

1 Like

Yes, you should try to increase the resolution and apply alphas.
This happened to me and increasing resolution fix the issue.

1 Like

Which resolution do you usually work?

Start 150, then 300 and for detailed alphas go up until 400-500, apply alphas and decimate to low detail and repeat for each mesh.

This is nearly 500k and I think is still jaggy for me, do your alphas looks like this at 500k ?
Thanks :slight_smile:

I think Josepmy is talking about dyntopo and set those values (like 300/400) there!

1 Like

You should turn on the wire frame and zoom in a bit closer to your object, so you can better understand why the edges are jaggy. It’s like a photo, the further you zoom into the image, the more pixelated it gets.

You need the high voxel density where you want to use the alpha image and not on the whole sphere … 500,000 is not necessarily a high resolution if the voxels are distributed over a large area.

Use as the others already said dynamic topology or 2-3 or 4 million … then it will be sharper and sharper, but also more and more memory consuming.

And YES, the alphas look like this at 500k if they don’t have blurred edges.

Your alpha image can also have an impact, because this image also consists of pixels e.g. 2000 x 2000 or only 500 x 500…

1 Like

So better work with blurred alphas, not Black and White one sharp. My alphas are 2000 px wide, it’s too small?

If I use dynotopo I got a similar result, do I need to push the dynotopo more, I think my Ipad will die :frowning:


I have made a video on the subject, maybe it helps you:

4 Likes