Failed to import previously exported project file (glb)

Recently when I was unable to import my previously exported project (machete) glb file back in nomad …
I am using a android phone with Snapdragon 855+ SOC and 6gigs of ram…

You can send me the model at

Here’s is the file and a video…
Sorry I had to compress the file to save on data…:sweat_smile:

I tried to open it (on desktop) and I didn’t have any issues.

The file is pretty big, 5Mo polygons, so I suppose that’s the issue.
I’m surprise you managed to save/export it.
In memory scene is ~800Mb (600 RAM + 200VRAM), it’s well below the 6Gb but maybe Android has other limits.

Instead of using the “Import” button can you try using the “Add” button?

I tried to add it into a empty scene but still it crashed…

Did you try to kill every other app or restart the device to make sure you can use as much memory as needed?

In any case I probably can’t help you further, the issue seems to come from the device itself (unless it fails with much smaller file as well).

Something that you can test is to try exporting a ~5-10M scene and see at what point it fails to load.

I tried importing a glb file (which was previously exported from Nomad sculpt) with 3Million polygons it worked as the project file was on 98mb…

But sadly with more than 3.5 million poly it failed to load… Is there any other way to import huge files?..
Thanks for the suggestions…:blush:

I found that it has nothing to do with the number of polygons in the scene… if the size of glb file gets more than 100mb , it fails to load the file…

Ouch maybe there is a limit to 100Mb on your device but it sucks if it’s the case, I’m a bit skeptical.

One thing that you can test to confirm:

  • export as glb so that the file weights >100Mb
  • save your project as well

Then try to add/import the saved project to see If it works.
If the saved project works but the export fails, then it means you got this 100Mb limit.

You can find the saved project in Android/data/com.stephaneginier.nomad/files/projects

The extension is glb.lz4, lz4 is simply a compressed format but the underlying glb is identical to the export.

Everything seems to work fine (I am able to export that’s more than 200mb), until I try to import back something that’s more than 100mb back to nomad… it crashes

The file which I exported from Nomad sculpt(glb format) -sizes 132mb

The same file which is located in android/data/com…nomad/projects(.lz4) -sizes 83mb

I don’t think I can do anything about that.

Something that you can try is to drop the file you want to open in the “projects” folder.
It’s best to make a copy of it because the file will be converted (or deleted/move if it fails).

I tried simply dropping the glb file in the projects folder…
Than I tried saving a project with same name of that exported file and than replacing the .lz file with my glb file which was manualy compressed to .lz…

But unfortunately non them worked for me (the file gets deleted by the app)…

Anyways thanks for the support…:pray:
Keep up the good work…:blush:

It would be great if we could export the metallic-roughness layers seperately, So that I can edit them later on some DCC app on desktop…

The file is always deleted, but it will be replaced with a new one that ends with glb.lz4.

For example:

  • you drop my_proj.obj in the projects/ folder
  • you launch the app and when you open a project you should have a project named my_proj (and the final file will be my_proj.glb.lz4)

Of course if Nomad crashes when you launch it, it means the conversion failed.

It worked but …I had to manually force stop the app because without force stoping it would delete the .glb file which was placed inside android/data/com…

Thanks a lot for your help… :pray:
Keep up the good work… :blush::heart: