Nomad Glb -> Blender help! Invisible meshes

Hello! This probably isn’t a bug, and I think it’s an issue on my part but when I export my model out of Nomad as a .gltf file and import it into blender it recognizes that the meshes are there but it doesn’t appear visible within blender.

I’ve tried seeing if I can reimport it into nomad using the same file and everything works, including the vector paint staying in tact… I’ve googled this a few different times and couldn’t find any videos or topics that would help me solve it so decided I’d turn here!

This isn’t the first time I’ve imported into Blender from Nomad, but this is the first time I’ve had this issue x.x I’ve tried to export it multiple times, piece by piece, all together, layers on, layers off… Would love some tips!

Can you double check the extension (so that it ends with .glb).

Did you use a usb key to transfer the file?

Just double-checked, it definitely is a .glb and my computer recognizes it as a 3D object.
I didn’t use a usb key to transfer the file, I uploaded it directly into dropbox and got it onto my computer that way. That way of doing it had worked in the past, though it was with a smaller model at that time (not sure if that’s an aspect.)

Does it work if you drag n drop it in inside https://stephaneginier.com/archive/nomad_demo?
Or https://gltf-viewer.donmccurdy.com/

Not sure what the issue could be.

This is the same problem I have had and still have with large files on a usb flash drive. You use usb key for export on blender or cloud service ?

I use dropbox to transfer files from my ipad to my computer. I save directly from nomad into dropbox and it generally is available right away, so a cloud service rather than a usb key.

it lets me view the file on https://gltf-viewer.donmccurdy.com/ from my computer so it really isn’t a file issue and must have something to do with Blender… hmmm I wish I had more knowledge on the program to figure this out x.x

It lets me view the file on the GITF viewer which seems like a good sign and means my issue is lying in Blender… Since I know it works and the colors are in tact I’ll just need to find out why it isn’t appearing in Blender. Thanks for sharing that link to the viewer, didn’t know something like that existed

I got it all figured out! Phew, it was a pretty obvious solution too so I feel silly. It was just positioned strangely and came in as a huge object.