Blender mesh won't import into nomad

I’m a bit stuck.

I created a mesh in nomad - exported to blender and then added a hair simulation.

The hair turns out fine in blender but when I import back into nomad it just brings in the base mesh.

I also converted the particles to mesh before I imported back into nomad but no use.

Mesh with particles in blender

Mesh reimported (this looks just the same as my original base mesh) .obj

.stl file imported successfully but looks really weird

Does anyone know what I might be doing wrong?

Have you tried exporting out as a .gITF file instead? If you’ve turned the hair into actual mesh geometry - can’t see why it wouldn’t work. Haven’t tried importing hair from Blender into Nomad personally so it’s a stab in the dark in my head.

1 Like

It’s really weird yes I tried to export the hair file as gitf but that didn’t work either.

Guess I might just have to export the whole thing into blender to finish it off

1 Like

It has layers according to your screen?

1 Like

Just checked and no layers stephane

If ‘Mesh 002’ is the hair from Blender, it’s only 63300 verts/faces - you’re going to need much, much more for what I saw in your Blender screen capture of the hair you made. Try really ramping up the count into the millions (2-3 minimum) and try again maybe? To quote Chief Brody from Jaws… ‘‘you’re gonna need a bigger boat’’ :sweat_smile:


Look at the last screen, there is a layer (red dot next to the name means there is a layer).

Otherwise, you need to have thickness in your hair.
It shouldn’t be just vertex and edges, it needs to have faces on it to work in Nomad.

1 Like

Haha great use of a jaws quote. Alright will try that and see

1 Like

Ok makes sense will play with it in blender thanks Stephane