App crashed

App crashed in middle of project, while trying to import png image from PHOTOS as backdrop.
Never came back to say peep.
I backed up all project files and everything else remaining, from FILES to DOCUMENTS.
I ended up erasing NOMAD and re-downloaded the new updated version.
Wich seems to work fine but wont accept any of the 22 files out of the PROJECTS-folder backup files.
No error message, just empty environment.
However, it is accepting 3 PROJECT-files out of the COLLECTION-folder.
I afraid i lost 2 weeks of day and night work.
Any clues ?
Please help.[quote=“3dnewbie, post:1, topic:1018, full:true”]
Bug reports

Hi there,
I am trying to continue my sculpting that i saved in nomad sculp ,but whenever i open it , my nomad sculp keep crashing.

Anyone have the solution how to open the file??

I’m confused by what’s going, what is “COLLECTION-folder”?

You are on Android or iOS?
Screenshots or a video could help me understand.

You shouldn’t have uninstalled Nomad, but if you did copy the Nomad files and still have them, you should be able to re-import them.

Can you elaborate on that, how do you proceed exactly to re-import the glb.lz4?
Do you use drop them all in projects/ folder and restart the app?
Or do you use the “Import…” button to load them back?


Thank u so much for quick response.
Ipad pro3 is the machine.
Everything worked beautifully on your otherwise wonderfull app.
Buying this app felt like a lucky strike and brought a lot of fresh joy to me.
Its been crashing though of and on, i believe dew to large file sizes.
So i amped up everything to maximum in in the history option settings.
I am not a computer guy, i hope explaining it good enough…
History to 4G and the stack limit to 2000, trusting that my machine shouldnt have Problem with it.
It crashed for good after attempting to import a PNG image fro, PHOTOS- app
Wich has been created in PROCREATE and depicted nothing but the number 42 (?).
The app would crash, but remained in standby in the background with a blank gray screen, where i could click on it and it would briefly snap to screen, only to immediately
Snap back into standby/blank/gray.
I was hesitant erasing nomad, but couldnt think of anything else to do.
I did copy everything related to NOMAD into DOCUMENTS bevor, and also made extra copy of everything that went into the trash after erasing.
So i have two sets of everything.
I downloaded NOMAD freshly, now with the last update, hoping that this might fix it.
The new NOMAD then would also not accept any project files, neither as import from DOCUMENTS, nor from the new PROJECT folder in FILES as i dropped the old files into there.
It appears that NOMAD brings up the propper environment, color e.c.t. , but it remains empty.
It does not appear to have anything to do with the file size, as they range between
8 MB and 350 MB.
Earlyer backups from collection folder, wich i created, still work.
But they have been kept separate from NOMAD all along.
I did try both, importing the files from within the app, as well as dropping them into
The new PROJECT folder, to no success.

Allow me to attach sample.
Ill send you a sample of the smaller files that dont work and one that still does.
Perhaps u see difference in the code ?
And a screen recording of the largest.

Sorry about the lengthy explanation,
Thank you for your time.


Ill send the good and the compromised file in a seperate email, this is the screen recording for now. (1.67 MB)

I just need a small file that doesn’t work, that’s all.

Crash is not uncommon if you ran out of memory, I can’t do anything about that.
4G for history is huge, but the history shouldn’t be much of an issue if you quit and restart the app regularly (as the history is deleted when you quit the app).
Closing other apps might help as well.

But you shouldn’t lost any file, and in the worst case scenario if a save operation is failing, you should be able to find the file in “Nomad/can_be_deleted”.

I did send sample files.
Tried a few more things here.
I dropped backup file into Nomad Project folder, restarted nomad, comes up as empty environment, but the file went immediately into the Can-Be-deleted folder.
But, here is perhaps a clue : the files must be a lot larger then they reveal.
I tried to send u 2 files, one good one bad, together they schouldnt have been larger then
20 Mb, or so, according to inspection.
But the mail-programm refused to send them dew to too large file sizes.
Wich means that they have been combined, larger then 100 MB.
So i send them separately, that worked.
Wich wouldlaso mean, perhaps, that the file that schows up as 330 MB , in the old project-folder, may also be a lot bigger.
Also the new updated version, keeps crashing , i.e. when using STAMP, on a really tight mesh.
I usally amp up the mesh to max until the warning message appears , just for fine detail.

What matters is the “free ram” value, if it’s low then it can crash at any point.

The filesize is a good indicator, but in some cases you can have a relatively small filesize that will take lot of memory in the app.
It’s typically the case if you create lot of layers.

Thanks for the file!
I’ll check them to see if there’s something noticeable, but for now I didn’t receive anything.
My address is

Turned out the file is not corrupted but for some reason the extension is incorrect.
Just rename “glb.lz4” instead of “glb”.
Not sure how it happened, maybe an iOS renaming thing.

There is hope at last.
I will try that.
Thank u for your help.
Much appreciated.

It worked !
Thank you.