What do I do if my file accidentally became too big?

I made a sculpt that I’ve put in some massive time into, and now I cannot open it. I have a copy of it, but it’s so many steps back in time I’d have to redo a whole lot of it…
If I could just delete my most recent step I’d be able to open it again…

You can check

I managed to save it by making a new project, deleting the initial sphere primitive and adding the project to the scene.

I can’t seem to understand however, how to locate the file without opening the project for future problems? I’m on iPad Pro!

Did you read the faq? FAQ
Use the iOS Files app.

Thanks, I did read it but as numb as I am I was looking all over my google drive, realised later I had to check my local iPad files and not my iCloud Drive files.

I have now located my file, but trying to import it into the nomad - WebAssembly link in chrome to delete the one mesh that’s messing with my file but it simply crashes my chrome too… meh.

My iPad has good storage and no other apps are running. I have tried restarting with both normal and hard reboot.

Any tips?

I don’t understand why are using the web demo. Browsers have even less RAM…

Did you try to reimport the glb in Nomad?

You didn’t read the faq :cry: .
What matters is the amount of RAM, not the storage (which is usually much bigger).

I’m constantly surprised to see the amount of people not understand the difference between storage and RAM, I thought it was something universal.


I followed your directions from another topic:

Perhaps this wasn’t the way to go, I am very tight time scheduled so I try to find solutions myself while waiting for replies.

I tried re-importing it into nomad as well, and that crashes. I have now re-created the entire thing so I guess this can be considered solved, the crash has been very frequent when I use “Simple merge” on too many meshes at once, even though they are very few vertices and the project is very small, it seems my iPad cannot handle the merge process very well.

I will be more cautious in the future and try to save a back-up project before merging larger amounts of meshes.

Thank you for your help and this wonderful app!

Please tell me the number, It’s frustrating if I have 0 information!
Polycount? Number of objects? Number of layers? iPad available RAM?

Either you are running out of RAM or you hit a bug (very unlikely as 1.65 is pretty stable, but possible still).
The stats displayed on the top left in Nomad are exactly there for that.

What do the stats says just before you hit simple merge and it crashes?

1 Like

I can re-simulate it for a test tomorrow and show you!