Crash on import and export

Started today.wont import any files wont export. Just crashes. Uninstalled and installed still the same problem. No error pop up just crashes. Using a samsung tabs7+ its been great up until now. Exported the other day,np.

Not that I have an answer, but it will be useful to post your import setting as a screenshot and the format you want to import.
I never had issues so far but tried gITF format only.

What is the size of the smallest file you tried to import?

Maybe close other app to make sure there is enough memory.

So i reset the app back to default settings. This let me bring in an obj around 1.47mb. Just tried an export. Failed the first time and then for some reason its exported. Ive just done this 3 times, seems if i hold the button down longer it works…really odd. Tbh there was an andriod update on the 29th. Part of me thinks it could have been that.just a shame i lost a load of work and for some reason i can’t sget into the android data to move files out. Which is a right pain. Seems samsung have put a block on it.

its spat it out at arounf 17mb

I’m confused on why you lost the file.
Do you still have a file that makes the app crashes? If so you can send it at

I don’t get if the issue is with the export, the import or Android.

The files are in Android/data/com.stephaneginier.nomad/files/

Also installed the Android 11 update on this tablet on the 29th, but no obj issues before or after. The file open dialog has changed a bit. Still can’t select files with the pencil, just the finger. I think the “open with” icon in the file thumbnails is something new (looks like a maximize button) . When I accidentaly hit it it tries to open objs with the calculator app for some reason. Just some random observations…nothing much else to add :frowning:

So once the crash started to happen i couldnt export any object. Even the sphere. This would not export in any format. I couldnt import in any format. It wasnt one mesh that caused the problem. I lost data as i ininstalled the app thinking this would solve the problem. This obviosly removed anything i had on the device. Once reinstalled the problem was still there. While looking for a solution i noticed in android files a revert back to default factory settings. I did this and its startrd to work after a few atempts. Hope this makes sense.

Im using version 1.36 btw

Argh ok, you shouldn’t have uninstalled the app.
Or if you do you can make a copy of the files.

Not sure what this option is, but it seems the issue might come from Android.
Maybe it’s a file permission issue?
My Android is stuck at 8.0 so maybe some things are different on newer version

Yeah i tried to get accses to the files but even with permissions it shows up blank in data. Not just for nomad,for eveything.ive been looking to get accses to my clipstudio paint files too. Aganin seems android ix blocking now on android 11. Might have toget developer tools to try and access. None of the file manager apps seem to be able to show data as well . Btw fantastic bit of software.i need this on my pc lol saves so much time

Hi all.
Seem to have found what this is. It would seem a app called files is causing the problem. I cant tell if this is google or samsung (tab7 +) and files is not accessible. So this is not file manager btw. What ive found is uninstalling the can do this via looking it up in apps and top right lets you uninstall the updates. Doing this allows you to export and import again. Just hoping a future update sorts this out.

1 Like

thanks! good to know.

I think I’m having the same issue as soon as I click add under the import tab app just crashes I dont even get to pick the file nothing. I understand if the file is to big but as soon as I click import/add whole app just crashes, is that whats happening to you ?

where in the top right corner does it allow you to uninstall an update? I’m running into a similar issue just having trouble trying to uninstall the update

I had that same issue, starting a day after reading this thread :hammer:

It happened after installing the “google play system update” (1.8 MB) in the settings (About tablet, Software Information…)

Uninstalled “Files” updates following your advise Coldesign, after that and it worked again. Thanks btw… It looks like this also gets rid of the “google play system update” too, so this may be the culprit … No idea Android is a mess sometimes.

@Articulated_Ninja_Re if there’s no 3 dot menu in the top right of the “App info” for the Files app, there’s no updates installed probably.