Export has broken

Hello. Exporting sculpts no longer works.

Little bit more info, when it exports nothing actually exports, it makes an obj file but then that file has a size of 0 with nothing in it.

Can’t confirm this…made OBJ and STL exports yesterday and it worked fine.

Are you up to date (1.68)?

Can you check it again today?

Ive tried all my models today with no luck. However Ive been trying to export old models, Ive not tried a newly made one.

It is up to date

I have just checked it again and checked for updates, its on 1.68.

Trying to export onto device and importing back to add also gives an error ‘unknown file model extension ’

Is it still 0b?
If so, what is your Android device? Android version?

Do you export to a Google drive?

I too am having this issue. Before the update, exports worked fine (onto Google Drive to computer), but now the file is 0 bytes too, and Cura doesn’t accept it like it did before. Got the latest version on my android too.

[EDIT] So I found a way around it, annoying but it works. I had to export the file directly onto my android’s download file. This actually kept its file properties. Then shared file directly to Google Drive and was able to download onto computer and load onto Cura. A bit of extra work but it works this way.

What is your Android version exactly?

Did several Exports today with STLs and OBJs. Seems to work so far.

I have android version 12.

It’s an Android bug only.

I know what the bug is but it’s not consistent which make it tricky to fix for now.
Typically on my Samsung Tab with Android 12 it works fine (export to Google Drive).
But on my phone (Android 8.0) I can replicate the bug (Google Drive only).

However @Noel_Wagner has the bug as well… on Android 12.

I found a way to make it work on my phone but then it doesn’t work on my Galaxy Tab.

I’ll try to find a way but for now the workaround is to export locally (not Google Drive).

@Earthly_E Android version? (Also, were you exporting on Google Drive as well?)

Maybe missing some Google drive update on Android12?

I don’t think it’s a Google Drive issue but rather an Android.
It has to do with file permission stuff, the way Android handle files is just… bad.

Anyway I’ll try to find a way.

I understand, deal with android ecosystem sometimes is very complex

Marking the thread as solved, I’ll make a quick Android update with the fix.

If the issue persists, just let me know.