Unwanted shadow flickering

The flickering apears when one or more lights are in the scene (it happens with the new sport light as well) and it flickers upon zooming and paning. It sometimes disappears at a certain amount of zoom.

The same artifacts apear when AO is on, even without a light in the scene.

These artifact get worst with imported geometry depending on its scale I think

I hope this gets looked at soon as it’s making lights and AO unusable.

Galaxy Note 10 lite, Android 11, latest version of Nomad

Scene details:
Default scene with default sphere (and some clay strokes) with one default light

If you are talking about the noisy ao/shadow while the camera is moving then it’s normal.
The render option are mostly there for static image rendering, when nothing is moving.

Did you try boosting the resolution?
You can max it out to x2.0 in the Settings menu.

The noise is visible even when the camra is not moving just like in the screenshot attached, so it does limit the amount of camra angles one can use for rendering or just visualising.
The flickering tho apears when the camera is moving.

I did try boosting the resolution, unfortunately it didn’t solve the problem.

I seriously have a problem with this term “makes it unusable”
This is simple drama.
I have to fight same issues. With AO mostly.
So I made this useless render with same issue:

AO could be optimised, sure.

But same I need to optimise my skills and knowledge with this app a lot. I know no other app for IOS rendering like Nomad.

Maybe we’ll find a solution together with lots of trying and optimising on user side as well.
But saying “makes it unusable” is a bit lazy :wink:

Just increasing resolution to 2 looks like this on iPad Pro 10,5”

I found out, that going to normal cam instead of zoom, there are artefacts again. Most of them are caused by vignette post effect, even when resolution is set to 2.0.
These are crops of very first camera view,
With Vignette:

Without Vignette but still anything else on, including AO and shadows:

AO is shading still in this “artefact” style.
No AO and light shadow is artefact free.
But coming back to my zoom picture above, there are almost no artefacts.

I think it’s some kind of some kind of dithering problem… This artefact is also visible on android version but on steep angles… Also rendering at a higher bit depth might have some improvement on this, (like rendering in 10bit)…

@Bnadem you can also try to use a denoise app afterwards. Nothing else is done by the high end renderer costing tripple a month what Nomad costs perpetual.
Or standalone denoise AI from topazlaps for 80€.

While sculpting, it is never a good idea to switch any post processing on, nor lights. This is done best with matcaps, I guess you agree.

See my answer in Screen Space Curvature for better surface detail visualization (+implementation details) - #4 by stephomi

I think there’s a misunderstanding happening here; I’m not talking about the typical rendering noise, I’m even surprised at how well it’s rendering given it’s a mobile app. I’m talking about this flickering (see attached) that happens when zoomed in at a certain level.
When these slices of shadow caused by light and AO cover my model I will simply not use them, nothing dramatic about this. And it has nothing to do with being lazy or unskilled

1 Like

Ah indeed that’s another thing, probably a driver/shader bug.
I don’t reproduce on my Android.

It only happens with the light (shadow enabled I suppose) and the SSAO?
Typically if you have one but not the other, does it happen as well?

Something that you can check is:

  • Interface menu → scroll at the bottoms and use “Logs”
  • check in the logs if there is something about “Internal Format”

You can try the options “Force nearest” and “Force rgba8” but I doubt it will change something.

Yes, it happens only when those two or one of them is enabled, in both PBR and Matcap

I don’t think there’s anything about “internal format” in Logs (see attached)

Enabling “Force nearest” and/or “Force rgba8” made some changes to those artifacts but didn’t remove them. I can take screenshots if you want

Sorry. You first picture just showed the artefacts everyone have to deal with. That wasn’t fitting to my cheerful mood regarding all the fantastic updates.
Apologies if I sounded a bit…you know.

I think I made the same mistake. If you take a closer look there is a bit of an illusion thing.
The screenshot only shows a simple sphere, not a geomery thing ahah.

No need.
I can’t reproduce on my Nexus 5X (old…) or my Samsung Tab S7.
I can reproduce on a Galaxy Note 10 with a remove live-testing service.

I’ll try to fix it if I can (remote debugging is not a funny thing) but honestly Android devices are such an annoyance -_-.

@knacki It’s alright, I knew a screenshot won’t explain much but I couldn’t upload a video being a new user, so I used a GIF later

@stephomi I’d really appreciate it! I’m loving this app so much that it was an instant purchase.

Hello again, I think this bug has somthing to do with depth/hight map - when enabled from debugging menu, the hight map shows those artifacts even though lights and PostProcess are disabled!

What I first thought are “shawdow artifacts” I think are depth slices, the distance between those slices get bigger as you zoom in, when a certain level of zoom is reached, the distance between the slices is too big that you find yourself between 2 of them, so they seem invisible - the same thing is happening to the shadows and PP when enabled, they are slices that get bigger with zoom, exacly as hight map does, so I assumed they must be related?

I hope somthing here makes sense and might be helpful in fixing it :slight_smile: I feel left out not being able to enjoy Nomad’s powerful rendering features :frowning:
Thank you

I thought it was fixed.
Can you tell me if you replicate in https://stephaneginier.com/archive/nomad_demo

Or by disabling « buffer reuse » in the debug options (interface menu)

Yes, I can replicate the same slicing/bug in the in browser app as well

Toggling buffer reuse doesn’t do anything

Do you replicate the bug on nomad - WebAssembly?

Not anymore! Last time I checked this web assembly there was the same bug, but now it’s fixed. Thank you!

Will we see the fix on the android app soon?

Yes it should be available for next release.

1 Like