Streaky bandy shadows

Bug reports… Hello I’m quite new to Nomad. I started using it around a month ago, and I think it’s an amazing program. Really awesome.

I’ve come across a problem. I was lighting a painted model, and I notice I get very dirty shadows that are grainy, bandy, and almost like stripes. I tried various lighting modes, like directional or spot, and that doesn’t fix it. I tried upping the resolution on renders, but I see the same banding as in real time.

The model started as an obj that I imported in, but since then I’ve modified it a lot, including remeshing, and the hair that’s casting the dirty shadows is something I created from scratch in Nomad. The only other thing I can think that would affect the shadows is the performance. I have 13.7M faces/vertices in the scene, and I’m on an iPad Pro 2020. Is this a possible reason? Is that too much?

I’m wondering if it’s a known issue and if there’s a workaround. I haven’t been able to find any other info on this topic. I’d appreciate anyone’s help. Ideally, I’m able to render out a scene with lighting all within Nomad so I don’t have to render in other programs. Thanks.

Here is an example of the problem. Uploading image. Thanks

And another view of the same area. It seems most pronounced here on the face as opposed to other areas. Not sure why.

Ambient occlusion, or reflection, or both. Just switch on off to find out. That’s when I experience this problem in certain cases on my iPad Pro 10,5” at least.

1 Like

Hello! Thank you for your response. I have verified that I get the problem whether Post Process is on or off. So, it’s not related to the AO or Reflections settings. Odd thing is that it’s most pronounced on the (imported) head of the character which has the most paint and texture detail on it. Any other recommendations would be helpful. I’m surprised nobody else is seeing what I see.

Leave post processing on and switch off ambient occlusion and/or reflection, there is your issue. If you switch post processing off, you have switch off ambient occlusion, reflection and anything else.
I have this issue not on every model, or not always visible that much. To me, it is topology and ram related.
Have you tried to duplicate your project and tried to decimate? Could make a difference…


99.9% sure it’s not ram related (would be a first).

Is the surface on the last screenshot smooth?
Display the wireframe and inspect it.
Do you have lights with shadows in your scene?

1 Like

Have you accidentally changed your render resolution?
Higher resolution makes artefacts less visible.

1 Like

Thanks for the tips, guys.

  • I tried turning off AO and Reflection with and without Post Processing, and there was no difference.
  • Yes, the surface of the face is smooth on my character. The wireframe is very high poly and even.
  • Yes, I have shadows on for the lights and objects because I want the scene to have a realistic natural effect.
  • I did not know about that resolution setting settings. It was at 1.25 and I put it to x2. It does help with the overall quality and smooths out the shadows a bit. But, I do still see banding in the shadows.
  • It seems that the banding gets worse when the intensity of the directional light is high. When I lower the intensity, it gets better.
  • If you look at the first image I posted as well as this one, you can see that the ear in the back looks semi-lit. It looks like light from the right is coming through the hair and lighting the ear. Isn’t that incorrect? Shouldn’t the ear be much darker? I wonder if that is related to the issue with this shadow.

I’m thinking the solution might be for me to render with all shadows off, and then render with them on, and then blend the two images in Photoshop.

It’s the light coming from the environment. Or point light if you have any.

Resolution on 2 is mostly for render only as it could take a bunch of performance. Don‘t know if M1 is giving such an extra punch to compensate?

Firstly, to address your comments. I checked and the light on the ear is not from the environment or from a point light; it’s definitely a spot/directional light. knacki, I’m not sure I know what you man by ‘M1’.

I found an interesting bug. I wonder if you can reproduce it. So, I realized that the light seeping through onto the ear is because the hair object is overlapping the ear/head object. I did a test with this box. When it’s a bit farther from the head, it blocks all light. But when it’s close to the ear, or overlapping it, the light goes through. That shouldn’t happen IMO. That’s a bug, don’t you think? In both situations, the light should not pass through. I’m not sure, but this may be related to the issue I’m seeing because the area in question should be completely absent of light.

1 Like

Sorry, thought you are on iPad 2021 with M1 cpu. I just checked first post again. 2020. Do you have a 4 Gig Ram model or 6 (1TB disk space) Just for interest.

Not necessarily.
I don’t what the parameters are (where is the light, how big is the scene, spot angle, shadow bias, etc).

If you can just send me the file with the issue (with everything set up already) and I’ll tell you quickly,

Concerning the blue leaking light.

The shadows are not precise enough, it’s one of the limitation.
The issue is not the objects overlapping but the distance between the ear and the blocking polygons (too small for the shadow map precision).

The bigger your model is, the worse the artefact.
Typically if you delete all the lower meshes (legs, etc), the bug disappears as well.

There’s no good solution.

  • move the spot light closer to the head (if you are fine with light not affecting the legs)
  • reduce the spot angle (same issue, it will light a smaller area)
  • directional light might help

Shadow quality in Nomad might change in the future but it’s not the priority at the moment.


Thank you for checking that for me, Stephomi. It is good to know the limitations because I wasn’t sure if it was me or not. I’ll keep that in mind in the future. It’s actually a small problem, and I think that I have a solution; I can make two PNG exports, one without shadows, and blend the two images.