Undo moving a mesh, also undoes previously renaming of a group when using two finger tap, will also undo whatever previous action was performed

Bug reports I think this is a bug, 1.67

1 Like

Seems to be undoing two moves at once.
Just repeated the problem again,
First I joined a few objects, then I named the joined objects, then moved the newly named object up a little ways and then tapped with two fingers too undo the move but actually ended up with both the move and the naming being undone, just to clarify, thanks

Do you have a way to replicate the issue?

The moment you let go the gizmo, it should have added a state (and increase the undo count to 106).
Do you use the finger or pencil?

I tried to replicate the issue using just primitive’s but wouldn’t replicate for what ever reason, I use my pencil to move the selected objects, and then two finger tap too undo, and yes I can replicate it, as a matter of fact it happened again this morning on a new sculpt.

Here’s the steps I took to reproduce the issue.

  1. Selected several objects
  2. Join selected objects
  3. Name the newly joined objects
  4. Select several other objects
  5. Move selected objects with gizmo and pen
  6. Tap two fingers too undo

Two steps are undone, the move but also the naming of the previously named joined objects.
Just tried it in the web demo and it’s repeatable there as well.

I still don’t replicate the issue.

I Tried it again and it’s still doing it,
The simplest way is create 8 spheres, select 4 and join them, name them, then select the other four, move them and then undo, the move as well as the naming of the other four will be undone.

Found the issue, the problem is the actual checkbox selection.

Thanks for the report!

My pleasure! Happy too help