Shading issues when texturing

Hey, I’m learning texturing objects, but encountered an issue with shading. Maybe someone more experienced could give some advice.

I have a simple mesh which I’m unwrapping in Nomad. It has only sharp edges and flat faces.

When rendering in Procreate, there are additional strips of different shading around the edges, they have width of one row of triangles. (I have marked edges of the model in red).

I’m wondering what exactly causes this. Should the topology be denser around edges? Should I completely retopology it? I tried UV unwrapping with Atlas and BFF, no difference between them.

In Nomad, you can disable “smooth shading” (Settings or Material menu).

Not sure inside Procreate, maybe do not export normals, I think they use an angle threshold.

Thanks @stephomi, but unfortunately that didn’t help.

Exporting with or without normals makes no difference.
Shading is even more pronounced when exporting to Quixel Mixer:

Did some more work, seems like increasing mesh density along edges fixes the issue.