Sculpting performance low after masking&transforming

On my android tablet (S7+, Android 11, Nomad 1.40, dex mode, with spen) there is some sculpting performance issue under certain circumstances… I could reproduce the same on my other android (Galaxy A3 phone)

Let me know in case you need additional input!

For repro:

  • duplicate default sphere
  • move two spheres away from each other
  • “simple merge” them
  • mask tap one of them

I’ll make a “story” of the rest of the repro, … seems easiest :wink:

1 Like

Since you got mask on the object, the transform needs to be applied “per vertex” instead of being “per object”, which is notably slower.

I don’t think there is any regression.
It’s simply the new “mask tap” that favors this particular use case much more.

That being said, I’m improving the transform tool so that the performance is the same as the Gizmo.
Rotate/Scale/Translate were applied independently, which is the cause of the slow down.

I can’t reproduce any slowdown on the sculpting side (S7, iPad Air).
My guess is that your phone didn’t like the previous slowdown so he limits the cpu/gpu.

When used in dex mode. Does screen on s7 turns off? Can this device be used as tablet/computer hooked to external monitor?

Hi, is it possible to utylize second pen button on android devices?

Thanks for your quick replies!

That wouldn’t explain the next step, after unmasking, when sculpting is fast again on the upper part of the object, but stays slow on the lower part of the same object. I was thinking the vertex ordering or optimization data structure might have been changed, but I don’t think the transform would do that, or does it?

I’ll try to isolate this slowdown a bit more, it happens in some other occasions as well while of sculpting and masking, independently of mask tapping and the new transform tool.

It stays on but you need some modern monitor that supports displayport over usb type c thunderbolt, or an extra adapter.

second pen button usually puts the pen in erase mode some apps support this already but there’s almost no samsung compatible pen around that has a second button except some from ancient wacoms on ebay, maybe from a note or bluetooth but not sure.

1.Yeah i know. Did you tried it via usbc or adapter?

2.As for spen question it was aimed for developer Stephomi. There are few 2 button pens like from dell canvas or acer conceptd that arent ancient. I was just wondering if android supports them or is it a hardware limitation.

tried usb type c

I think it should work, but I only have a Spen with one button so I won’t be able to test.
I don’t really want to spend too much time on that for now, but one thing I could do is try supporting it (with choice between smooth vs add/sub).

That would be a unique thing. If you need to debug anyting i can help. I own Asus vivotab note8 and cube mix plus, windows tablets with build in emr that support those pens.

On next release, for 1.41 I’ll add the secondary stylus button.

No, only local dynamic topology can do that. Most other topology algorithm will run a reordering pass if the score is too low.

I fixed a bunch of issue with 1.41, there has been a lot of changes in 1.40 concerning painting and normals. One issue concerns the normals (Inflate tool broken), maybe there were other side effects but I doubt so.

I don’t think it’s a regression either, I’m seeing this on the web version as well (which is 1.38) but not that noticeable. I’m trying to make repo steps that work on the web version maybe a video.

It’s a bit of a mystery why sculpting on the same object has difference performance in different places on the same mesh