Recently deleted nomad then reinstalled. But lost previous files

So nomad for some reason kept crashing when trying to open a recent project. It was 5 mil verts in the scene. I’m running an m1 iPad and it’s not even my biggest file. I closed out all background apps and reopened and still no luck. So I uninstalled nomad not thinking to backup my project files and not knowing iOS will delete the app files and upon reinstalling I have zero project files and everything I did this year is gone. Is there any way to recover those files?

You can try looking in the iOS Files app - Recently deleted categories.

For the faulty file, you can send it to me if you still have it.
Polycount is important but other stuffs can matter for RAM as well (textures and layers mostly).

The file is nowhere to be found. Not even the recently deleted in the files App. I was assuming the app directory would remain the same upon reinstalling. This is unfortunate I had to learn to backup my files due to this mishap. I had over 40 projects that were stored only in that app directory 3 just finished and 3 wip. I’ve watched hundreds of tutorials and none of them warned viewers about this :tired_face:

That’s not a nomad thing, that’s an iOS thing. Did you read the warning when you deleted the app?

Sheesh. It did it so quickly I didn’t notice. And it was on my iPad so it may have appeared a little differently. Must have overlooked it

Is there a way to recover the files though? This done happened to me. Nomad was acting wonky so I thought maybe delete it and reinstall it thinking the files would’ve been saved in some way…. It no projects of mine are to be found now

Unless you saved them somewhere else, they’re gone.

“Deleting this app will also delete its data.

If Nomad acts wonky, simply delete the settings.json file in the Nomad folder.

1 Like

Sorry if this is a rather naive question, but if I copy a project in the Nomad projects folder on my iPad, and then paste it to a different folder in the files app on my iPad (a folder outside of the overall Nomad folder); then if Nomad was ever deleted, then the copied project would still be saved on my iPad? Sorry if this is obvious question, but prior to getting my iPad I have only ever used windows, and iOS seems to do many things differently from how I expect.

1 Like

Only the Nomad folder is getting deleted.

1 Like

Did you check iCloud? I’m not sure if the project folder would be sync’ed there but it’s worth a look.

My iCloud is full. But it app data won’t sync with iCloud unless I copied the files there. I’ve accepted this loss

Experiencing another possible lost files situation myself. A forum search with keywords “glb” or “nom” didn’t bring up anything relevant.

WIth a day’s notice to swap out my iPad Pro (failing usb-c port) for an exact replacement, I located my sculpts in the Projects folder. I noted they were in “glb” format. With OSX’s Universal Control feature, the files were copy/dragged for safekeeping on the MacBook.

Starting from a fresh iPad Pro, all the apps were loaded and I proceeded to copy those files back into Nomad’s Project folder. Nomad would launch with a brief message about missing thumbnails:

And would ultimately fail to load giving a momentary message:

At this point, all the glb files in the Project folder would be moved into a “can_be_deleted” folder en masse.

The new install has a penchant for saving files to the nom format. All my sculpts were started before the new format was available.

The saved glb files look to be the correct size. It’s just that I cannot open them now.

I tried deleting the settings.json file, but that didn’t help. Any other suggestions? Is all hope lost?