My Nomad Library lost?

@stephomi may the the only one with enough insight to definitively answer this.

I was hoping for the chance the latest 1.77 beta releases might somehow fix this, but the problem repeats with the same result as identified around 2 weeks ago.

I did an iPad Pro replacement under short notice so concentrated on migrating one of the more important things from the old device: my Nomad library. A dozen of the Project Folder’s GLB files were duplicated to my MacBook.

The iPad Pro was replaced with an identical one and after the hardware/OS setup process, I then copied those GLB files back into the Nomad Projects folder.

Launching Nomad for the first time, I immediately see it sequencing through all the “missing thumbnails” (?)

Without still touching anything, it lands on the canvas screen with an error message at top center.

Despite what the error message indicates, I wasn’t opening my Tyrannysaurus sculpt.

Checking into the iPadOS Files app, Nomad has taken all 12 of my GLB files from the Project folder and automatically moved them into the “can_be_deleted” folder.

Import > Add to Scene is the only way to select a file outside the Nomad Projects folder. When I attempt to select a GLB from the “can_be_deleted” folder, it only gives another message I’m not understanding

Taking one of the less important GLB sculpts and running it through the GLB-to-OBJ converters Google has suggested only results in an error message from the top two resulting sites.

I’ve tried deleting the settings.json file, but the process seems to result in the same failure.

Is library recovery in Nomad a lost cause?

One of the sample GLBs I’d been working on…
PigStroke.glb (5.7 MB)

The file is named “PigStroke.glb” but it should be “PigStroke.glb.lz4”

Not sure at which point the extension was stripped.

1 Like

THANK YOU Stephane! That was the missing clue!

You’ve uncovered some sort of bizarre behavior in the iPad - MacBook interchange!

Let me try to document this best I can…

My iPad Pro exchange/replacement was scheduled for May 1 at the Apple Store. To cover any catastrophes, I set the iPad next to the MacBook to use the Universal Control feature…. Where the (MacBook’s) mouse is able to dance and interact across both screens seamlessly.

On the iPad Pro side, I open up the native iPadOS Files app to display the contents of Nomad’s projects folder; all my Nomad sculpts

On the MacBook side, I readied a Finder window to safekeep the files.

I don’t recall which sequence worked, but I’m certain the first thing I’d try is to mouse-select all the iPad files and drag it over to the MacBook Finder folder. If THAT didn’t work, I would have selected all sculpts on the iPadOS side and chose COPY. Here, I would’ve relied on Apple’s Universal Clipboard feature to PASTE anything that was recently copied on any Apple device.

I think the former worked from the onset. Keep in mind, I wasn’t paying attention to what the extension exactly was on iPadOS side or MacOS side. What’s definite is that the untouched folder on the MacOS side has all those sculpts ending simply with “.glb” and all dated May 1st.

Insert here my 2 weeks of confusion not knowing why dragging these files back to the replacement iPad Pro didn’t work.

With your help today, the first thing I immediately did was drag pigstroke.glb from MacBook to iPadOS Files app. The unchanged pointer on the iPadOS side indicated this wasn’t allowed, so relying on Universal Clipboard, the file was pasted. However, nothing in that app’s default UI showed that I could (use my finger to) rename the file or its extension (long-pressing the file name did nothing)

Focusing on the MacBook side, I duplicated all the sculpts in another test folder and in MacOS added the “.lz4” extension to all. Took one of the test files here and again relying on Universal Clipboard / Universal Control mouse-pasted the file into the Files app…

What appears in the iPadOS folder?


A-HA! J’accuse Files app!!

At THIS point, I use my MacOS mouse to long-click on this file sitting in iPadOS and here it finally permitted changing the extension. I ignored the iPadOS warning about changing extensions and was finally able to open it in Nomad!

As I was hurried for time on May 1st, I went this route with iPad and MacBook thinking it would be the quickest and most direct way of moving all those files.

The notion of opening each one to Export up into iCloud would not have been my first choice procedure. Rooting around my iCloud folder just now, it does appear I’ve done this with a few sculpts previously as I did find this file properly exported (name wise) back in 2021…

This leads me to wish I had the option of simply saving/opening on iCloud. As far as I can tell, Nomad’s Open dialog is only locked into the local projects folder. I understand there can be complicated logistics of what happens when the user’s iPad is entirely disconnected from WiFi/Cellular and a save needs to occur so I won’t dwell on this wish. I do have some Affinity Design (vector illustration) files on iCloud where both iPad and MacBook have easy access to it and had hoped for a while that Nomad sculpts could be centralized.

Thanks again for solving this Stephane :+1: