Project disappeared! Argh!

Been working my model. Close my iPad, but didn’t close the app. Came back tonight and all I see is a blank new scene! I go to open my work file and there’s nothing to open! Argh!! Time for a drink…:stuck_out_tongue_winking_eye::+1:t2:

You didn’t save your model?

Auto save has some limitation.
Typically if the model is too big I display a warning at the bottom but people tends to ignore it.

Also, it only occurs when you move the app to background or quit it, but it can still fail because iOS imposes a time limitation.

I plan on changing the way auto save works but there’s no magic way, I’ll have to interrupt the sculpting workflow or something because saving 3d models is not the same thing as saving 2d images.

@stephomi I think the way I’d solve this is with an non-intrusive in-app notification.

In fixed intervals (e.g. 5 minutes), a notification would hover somewhere visible for 10 seconds, offering to save the model with a tap on the notification. After 10 seconds, or after being tapped on, the notification would disappear.

I think this has the advantage of not interrupting, and not even requiring any engagement, if you don’t want to save at the moment, while at the same time providing a reminder that is easy to act on.

I understand that this might sound similar to how things are handled currently, however it is different in that the current notification is static and always present, hence easy to forget, and hard to act on (you still have to open the menu and save the regular way).

Yes this is what I have in mind.
I wasn’t a big fan of « save when quit/exit ».

Update.

Hey Stephane, so I’m saving OFTEN but still some times I’ll be working on something, save close my iPad, come back to my project and I either see a new scene with a default sphere or I’ll see my project but not the recent version.

Also, sometimes when I see a new default scene upon coming back to my iPad I’ll try to open the saved project I want to work on. However, I don’t see any of my saved projects! So I figured out that if close and restart Nomad I then see my saved files and can open them.

FYI, I use nomad daily and this has happened every couple of days.

You mean you are not seeing the preview or there is no projects when you click on open.

If it’s latter then it’s really weird.

Maybe a video could help me understand.
Are you projects so big that sometime loading them can fail?
Typically if you launch the Nomad and the app crashes at startup (fail ta load file), the next launch will simply open the default scene, but your other project is not lost though.

Yeah I’ll take screen grabs next time. What is see are files showing “IMG’ files with nothing in it.

Thanks!

Hmm I don’t get what IMG files are.

To clarify, I’m only talking about the “Project” part, not the export/import.

Hey Stephane,

So attached is shows the “IMG” files. So a couple of things here.

-This open project window shows my projects but also shows these generic “img” files that have nothing in them. I marked these with red “X”.

  • So for my initial issue, sometimes when I go to open a projects I only see these empty IMG’s and maybe one old project. I then close and relaunch the app and see all my projects again (like this attachment).
  • When I open on of these files it’s completely empty. No default sphere of anything.

Thanks,
Alan

I have no idea what those IMG files are :neutral_face:

Did you fiddle with the project folder directly or let another app writes in it?
Can you tell me what do these files represent (extension? if it’s an image what does it look like?)

Thanks!

Just so you know, if you drop some 3d model in the project folder, it gets converted when you open Nomad.
Also… by doing that it also open these model as a new project.

Nomad try to convert those files, but instead of failing it’s making these empty projects (this bug will be fixed on next release).

For now I’ll make sure it fails and move the IMG files in another folder (on next release, any file that fails to load - whether it’s a matcap, alpha or project - will be moved to a folder named “import_failed”.

Nope, no fiddling with the project folder. I’m not that techy. You got me thinking about the projects folder. I opened it and took a screen grab. I’m also sending you a vid of what happens when I open one of those files. Theres nothing in the scene. Strange eh?

(Attachment RPReplay_Final1600466955.MP4 is missing)

Wait a minute! I did drop or import a 3D file. In that screen grab is called “road” towards the bottom left. I could’ve sworn I imported rather than moving it to the Projects Folder in Nomad. I wanted to drawing a shape I made in another software. Ah the plot thickens. SO, should delete all those “img” files.

Actually since I convert the IMG files into project file… I also delete the original IMG files, so that’s why you can’t see them anymore.

When you use the import button it indeed create a new project file as well.

Hi Staphane,

Okay here are two clips showing what’s happening.

  • working on a project and saved before I closed my ipad.
  • came back to Nomad and found a default sphere instead of my project. Then I go to Open my project and I don’t see any of my projects.
  • I then close Nomad by swiping up. I then relaunch Nomad click on Open and voilá my projects are there!

(Attachment Video.mov is missing)

(Attachment Video_1.mov is missing)

Clips are missing for some reasons :slight_smile:

But I don’t think I need the video as I understood the issue and how to fix it.

The only thing I don’t know is why those IMG files appears in the project folder in the first place and what they represent but maybe that’s an issue on your end.

Morning.

  • sorry I had to upload clips to twitter. I can’t load them here.
  • I have opened one of those blank files and there’s nothing in them, to even the default sphere. I will take a video the next time it happens. :+1:t2:

I saw the images on twitter but the extension is glb.lz4 which is the Nomad project file so that this point nothing can be done…

To make things clear, there are 2 issues:

  1. IMG.PNG files appear in theyour project folder
  2. when you start Nomad, those PNG files got converted into empty IMG_PNG.glb.lz4 project files

As I said previously the point 2. is going to be fixed on the next release.
So basically, the issue will be solved.

However I still don’t know why the point 1. happens in the first place.
You should try to look into the folder before opening Nomad, not after.

It’s not a big deal though, but I’m just curious to know what the png represents.

Man, I feel bad for my thread here. I gotta balance it out by saying I love this sculpting app and use it everyday. I try find things to sculpt with nomad all the time :+1:t2:.

The main issues are:
1- having my wip project close for no reason and having a default scene instead.
2- then when trying to open my previous wip file I see a window with all my projects missing. Again, they show up when I close and relaunch nomad.

Yes I know but this is a consequence of the IMG conversion into new Nomad project; so it’s going to get fixed as well.

For the second issue I’m not sure, maybe it will be fixed as well.

Ok I found the issue about the IMG files :partying_face: !

For some reasons it had to do with… images that were dropped into other folders such as backgrounds, images or environments (maybe it only impacts the backgrounds folder but I’m not sure).

Anyway, it’s all going to be fixed on next release.