Off axis symmetry no way to fix it

image
I can’t figure out why the axis is angled weird for the symmetry on some parts of my sculpt but fine on other parts. Is there anyway to fix it? Ive tried local, world, reset. Is there some sort of number way of zeroing out the axis’s ?

World and then reset world center should fix it (unless you moved the model of course).

Is it just the line being displayed that is wrong or the symmetry itself as well?

The symmetry is off too. They are moved parts but did not really rotate them that angle. Tried switching to world in the symmetry and still looks off.

From the screenshot the model is not aligned with the grid, maybe go in gizmo and reset the transform.
I’m not sure what you did but it doesn’t necessarily mean something is wrong with Nomzd (bug report).

If you really think there is a bug, you can send me the model and I’ll take a look.

I could send you a file. Is there PMs here? And it’s about 30 mb. It’s possible its my error but I can’t figure out how it got that way when it worked fine before. I was using local symmetry for a few weeks with no issue.

As Stephane said. The model with all parts is obviously rotated.
If you realise an issue before reopening your file, you could search in the undo history when this happened. But as soon as the file is reopened, which can happen after closing your iPad, the und history is purged.

But I have an idea which can probably solve your issue.
Select one object of your model.
Select the gizmo tool.
Tap on gizmo icon on top bar and check rotation.
Everything should be on 0.
If not, you have an easy chance to be back in precise symmetry when entering 0 for every rotation axis and object. But! Save under new name before this!
Incremental backup is always a good idea.
Also for issues like this btw. when suddenly something happens one can‘t explain.

Good luck.

1 Like

Unfortunately this happened lol!

It‘s also moved, not rotated only if I compare it with the previous picture, isn‘t it?

Sort of everything

The email is at the bottom https://nomadsculpt.com/

I don’t think the issue is on Nomad side, but the solution is different depending on the situation (matrix baked or not, etc)

I sent you the file Stephane. the problem areas are the main face which I kind of fixes with the gizmo adjust but it’s not dead on, the legs and arms, the eyes, eyebrows. The nose, hat and main body are aligned perfect.

The main issue is that nothing is aligned (see the model relative to the grid).

Local mirroring should be used exceptionally, usually you want to sculpt on than object that is centered by default).

I took a look but there is no way to fix it easily.
There are lot of parts where simply switching to « local symmetry is fixing the issues.
(Don’t use « show line » but instead use « show plane » to understand what’s going on).

One alternative, and that’s probably what I’d do, is to set mirror world (and reset direction/center) and then try to reposition everything on the centered on the world centered. It’s impossible to recenter everything easily so you might need to use « mirror left/right to really validate the mirroring.

I’m starting to think adding « local » symmetry was a mistake in Nomad, or more specifically, I should have hidden it a little bit. I feel like it doesn’t encourage the correct workflow which is to have the same symmetry line for all mesh (default world space).

1 Like

Where are all these options I’m not seeing them under the mirror controls. I kind of wonder if you can merge all objects and reset it that way?Than break them apart later?

I also own zbrush and am well versed in blender. I think they could correct the issue? It would be nice to be able to simply zero out the axis at any point.

I noticed many stuffs are not perfectly mirrored (body, scarfs, head).
So it’s up to you to decide what’s symmetrical and what’s not.

My general advice would be to leave symmetrical to world, make sure the object is centered. (note that it’s usually like that in other software, and it’s the default in Nomad).

Here’s how you could do it, without merging.
Basically by selecting each object, resetting the symmetry line and reapplying mirroring.

That helped a lot! I got a workable symmetry back!