Object size affects shadow softness?

Not sure if this is a bug or just how it works, but putting down a plane to catch shadows, I noticed that the shadow gets softer the bigger the plane is:

Also, undoing from the huge-plane left the scene shadow bias all weird, which I think counts as a bug:

1 Like

Could have been due to the resolution of the plane. Yeah, just tested it out.

The rest, no idea…lol

See, that was my guess, but it didn’t seem to change as I cranked up the plane resolution (pre-validation, at least).

The size of the scene has an impact on the shadow resolution, it’s like that everywhere (although shadow resolution usually has a higher resolution on desktop).

If you need a big plane, you can disable “cast shadows” in the material settings (the plane only needs to receive the shadows).

1 Like