Mask extraction not working correctly - v1.9

This is a two part report.

  1. the shortcut for clearing the mask is not working on the mask tool when you hold the mask button and swipe up. The shortcut is working on the mask SELECT tool but not the standard mask tool.

  2. I’m getting horrible results with the mask extraction now. I’ve remeshed the geometry to around 300k and the extracted pieces are hovering over the masked area vs being directly on top and also the resulting geometry is horrible and not clean like it used to be. I’m not 100% sure if this a bug or something I’m missing due to the update. I was shown these issues by a friend and I can’t find the solution to resolve it. Thanks for helping.

  1. Working fine with me. Sure you selected the correct object?
    It only clear mask for the selected object, also if symmetry is on, the mirrored shape shouldn’t land on the mesh either (that’s probably the issue here)

  2. Use shell…? it’s not an update thing

Ok here is a new video with a new scene. So if I keep the closing action to fill I get the same result as the previous video. Horrible geometry and floating off the model. I also cannot clear the mask with the mask tool (only works with SELECT mask tool) and since there is only one object it is selecting the correct object.

Taking your advice I switched to shell extraction and it made a huge difference. On the previous Versions I have always kept it of fill and never experienced it like this. I was able to use the shortcut to clear the mask as well but can’t do it while using the mask tool.

Hope this information helps.

Thickness was simply ignored for fill/none options, so I’m not sure what you are trying to do… just use shell or don’t set thickness to 0 if you want fill to work as before.

I don’t know what you are doing but you can only clear the mask with empty shape on background (so only with the SEL_MASK tool…).
The sel_mask tool can be triggered from holding the shortcut on the left and start dragging on the background.

Got it. I’ll take a note and just leave the mask extraction to shell. That is the result i was looking for.

I’m probably not explaining the clear mask issue correctly, so apologies if it’s confusing. Basically with the mask tool selected, I draw a mask (doesn’t matter what shape), I then use my finger to press on the mask button (left hand side of the screen below smooth icon) and swipe up with my apple pencil to clear the mask. This had worked in prior versions but now I can only do this if I switch to SEL_MASK.

I re-read your last message about a shortcut and just discovered a new window that a CLEAR ALL button. This is a user error, not a bug. Apologies, just getting used to the new layout.

Thanks for the quick responses :slight_smile:

If you see a shape (lasso), then it should work.
The tricky thing is that you need to hold the button, which isn’t possible if the mask tool is already selected (the icon will either be greyed if the toolbox mask is selected, or it will unselect the button if the shortcut mask is already selected).

But yes with the clear button, the shortcut are less important now, it’s mostly meant to be used when you have another tool selected (or with the keyboard).

1 Like

Makes perfect sense now. Appreciate you explaining this because a few of my sculpting buddies were just as lost as I was.

You have “sculpting buddies” ?

yeah, just a few people who i met online over the years from using nomad. We typically pass models back and forth and do collaboration pieces to help push each other. When one of us can’t figure something out we try to help solve the issue and when we’re all stumped we either ask for help or report bugs.