Layer brush not work

Bug reports

Its seems that the layer brush not work. She do nothing even with active layer, only color work.

Its seems that no pressure pencil detection, if i uncheck pressure and intensity its work but i don’t know if that works good.

Édit : randomly work one time if uncheck and check radius or intensity box then it does nothing after one stroke

Edit 2 : when i press on the object with my finger pencil re-work … weird

Can’t confirm. Looks like there are no problems here.

There must be something as I had the same trouble as our friend. He and I must have posted at the same time…

1 Like

I unchecked finger sculpting some time ago. Does that make a difference. Please do not ask me where I did that :rofl:

I tried that, and it didn’t solve it. Nothing did. As I said in my post. A complete reinstall solved it. Bit drastic I know. I just made a backup of the whole Nomad directory in files (named “Nomad old” then I slowly copied everything back over apart from the settings.Jason file. That did the trick, but I have no idea why it happened, apart from maybe memory corruption issues.

Setting.Json lol. Love this iPad spellchecker.

Shit, what an action!
I tried around with layer brush, but no issues.
IOS 14.4 iPad Pro 10,5” 256GB Nomad 1.41

Hope the issue is solved soon.
And I hope you have a Mac. I am on windows. Copying was always via Dropbox. Drama!
Now I have fast internet, but before it was a pain. I recently found FileBrowser a big help, as it allows you to copy on your PC via WLAN, which is a serious amount faster.

You should never re-install Nomad!

Maybe you have a “layer” (not the brush) activated?

The behavior of the layer brush is different when you sculpt on on actual layer. (as long as the option “use current layer offset” is enabled in the tool setting).

If i re install, i keep my projects and alphas ?


People should stop doing that!
What you can do is copying Nomad folder or simply rename a file to make a backup.

Typically rename settings.json and tools/ folder and you’re almost back to factory settings.

1 Like

I renamed the settings.json and tools file … identical results … So I saved my alphas and projects directory elsewhere on my ipad then I completely reinstall the application. After the first start nomad suddenly closed 2x the 3rd time it finally started but I had lost the last project … luckily I had another recent backup. I also noticed that another little problem was gone, when I killed the app and reopened it I didn’t have a new empty scene like at the very beginning. In short, it seems to be working for the moment.

Just to be clear. Nomad doesn’t save any internal data, everything is in the Nomad folder.
That’s why reinstalling Nomad is completely useless, deleting or moving the public Nomad folder gives the exact same result.

You should copy the data folder as well, thumbnails (and autosaves) are in there.
If it’s missing it, it needs to regenerate the thumbnails, thus the long freeze if you have lot of projects (or high poly ones).
You can check if the lost project is in the can_be_deleted folder, typically if the freeze is a very long it might fail for some projects.

Not sure what the problem is.
At the moment, if there is a missing thumbnail the file regenerate the thumbnail and becomes the current project. Otherwise the file to be opened by default is stated in settings.json.

Conclusion: if there is an issue with the layer brush:

  • check stroke and pressure settings
  • check if you are sculpting on an active layer (and if that’s the case check for “use current layer offset” option in the tool setting)

Ok thank you, it’s very clear;) but I admit that patience is not my job lol. And since it didn’t work the first time I was there in force lol

Hi Steph.
That’s precisely what I did. I only reinstalled the basic Nomad app. Then (albeit tentatively) put all the files back. It’s running fine now. Just need that iPad Pro 2021.

Ok I missed this phrase.
I’m now very confident you were simply sculpting on a layer with the option “Use current layer offset”.
If the layer was already sculpted and if the brush size was smaller than the layer deformation then it won’t have any effects.

Thanks Stefan. I will watch out for this if it “duplicates” in the future. Your App is amazing and I am saving up for a 2021 Ipad Pro just to use Nomad. Shows how good you are. Take care.

1 Like

I’m having the same issue with my iPad pro with the layer brush, it seemed to work initially but has since stopped altogether. Is there a clear resolution to this issue?

Are you sure you are not doing the following?

I can’t seem to find that option but I haven’t added any layers. I noticed when I switch allow unrecognized pressure off I can use my finger with the layer brush, however it only recognizes the pencil once following use of my finger, then it’s not responsive.

It is the first gen iPad pro, could this be an issue?