How do I prevent boolean when merging?

Can you stop Booleaning with a merge?
So made an sculpt with like… 6 shapes and merging them makes that negative space. I didn’t realize that until I went to set it up for 3D printing and saw the layers or empty space that would 100% not print. Is there no way to just like fill the entire space?
Thank you I’m advanced. I have like…a week of experience and the learning curve is rough.

I don’t get it.

Are you talking about voxel or simple merge?

Also, boolean is precisely what you want if you want to print something, to avoid internal geometry.

I’ve tried voxel and a simple merge and I’m getting splits like this. The eyes, limbs, and tail would just not be attached to anything. Thanks again for getting it back to me.

I’m not sure what I’m looking at, or what steps you did exactly.

This part confuses me so it might be the issue, you either use one or the other.
You cannot simple merge once everything has been voxelized.

Did you perform a voxel in the end?

1 Like

Looks like the picture provided is showing a slice in the slicer for 3D printing. I think maybe you’re doing a combination of simple merging and voxel merging that may be messing things up. Just to step back for a second:

  • Simple Merge lets you combine multiple objects into “one” object. It keeps all of them separate and unmerged within the one object.

  • Voxel Merge combines the objects together and creates a new mesh with a hollow center, all one object.

    • when Voxel merging a visible part with a hidden part the hidden part gets cut out of the visible part.

It looks like you’re simple merging and voxel merging in such a way that you may be unintentionally creating those holes >> Perhaps Simple merging visible objects with hidden objects, then Voxel merging? This may cause the hidden objects to boolean “cut out” of the voxel remesh of the visible objects.


Ok, that makes a bit more sense. I was looking at the grids more so with merging and was going straight to voxel bc it allowed me to move more like one giant chunk of clay when I was ready to sculpt.

I’m going to go experiment. Do you think the sculpts I already did all…voxelly/simple are too messed up not to redeem? Maybe I can just… idk shove a new shape in the negative spaces?

You can try shoving a new shape in there but not sure it will work. You could also mask a portion of the sculpt, separate it, then mask the negative space mesh and separate/delete it. Then combine the first mask separated section back to the rest. Not sure if that makes sense but it may be easier than trying to close the negative space by inserting objects.

1 Like

Voxel is a lossy operation, simple merge is not.

If what you want is a single manifold shape without internal part, then voxel remesh guarantees that.
Voxel remesh cannot output the mesh that you showed previously.

We can’t help you much if we don’t know how many meshes you have in Nomad and what they look like.
You can use voxel remesh on a single mesh, but also on multiple mesh at the same time (in that case it works similarly as: “simple merge” then afterwards “voxel remesh”

Edit: just saw your insta DM. I think using voxel remesh will solve both of your issues (trim, intricate eyes).

1 Like

Easiest solution is if there’s an option in you slicer software like ‘union overlapping objects’. Most slicers have that option.

I reached out to nomad and they said the problem was I was using voxel before simple merge bc I was just focused on the wire frame. The simple merge filled all the empty space even though I lost detail. But at least it’s closed up.

Yes, that was the problem. I didn’t realize it wasn’t used separately.

Unfortunately the only slicer I have access too is pikaslice which is made for iPads and it’s…not as well tested and explained as every other one.

You can try some online service like Free online stl repair tool

It makes a union of your objects without losing detail that comes with voxelization