History Stack MB Limit & Undo’s

Hi Stephane! This isn’t necessarily a bug that I’ve found more so of a grey area I suppose. As you’ve seen, I’m a bit silly with pushing memory to absurd boundaries to finish off my pieces, in order for me to continue working on the sculpts I make in Nomad I often force reboot it to free up memory by wiping the history stack - so I altered the default 400 mb limit it for this particular model so I had a bit more memory to work with before I force rebooted (tool settings revert, alphas go back to default textures etc. have to constantly configure them again). The history still logs I’ve done something (set to 3000), but reverting back doesn’t actually undo the actions I did. I get this is to do with the greatly reduced mb limit I set, normally there’s a help message or a warning, or something when settings like this are changed and it adversely affects what you then do on the scene. Not a bug, just thought I’d bring it to your attention, thank you!

Did you read the tooltip?

1 Like

I did, it just didn’t have the same informational effect as the warning messages (like trying to output 4K red warning). Editing the model afterward is basically one-hit, can’t undo it even though the history of your actions are there (when using low mb + high polys on scene). I know it’s niche and not a lot of people will even be toying in this area, just seemed a bit of a greyer area that’s all.

I don’t understand

I used the crease tool, started carving into the mesh, I just slashed at it several times for a test, then hit undo. The crease cuts didnt vanish, the history had reverted though. Since your reply I’ve tried to replicate it, but now they’re un-doing as normal, I’ve rebooted the app since original screen shot for memory refresh. I will screen shot more if it happens again. There was more in the history stack at the time when this happened, around 100 and ram was much lower. Will document further on thread if come across it again in future. Thank you for your time!