File doesnt load, empty scene, thumbnail ok


I think i just got everyones worst nightmare. File “opens”, nothing is loaded in the scene, tried restarting ipad, app, everything… i Even tried duplicating and renaming the new prj in nomads files but it never recognises the new project. ``Tried “add”, but nothing…

Has anyone encountered this before please is it a known bug with a workaround?
Is my project safe?

It makes me kinda sad because the worst bit is that i cannot continue using the app with that fear looming :frowning:

Hi and sorry about that.

Yes it sucks, but I don’t know where it’s coming from.
I might have a fix for next release but I’m not 100% sure as I could never reproduce the bug.

You can send the file at (the lz4 or zip is fine), and I should be able to recover the file if that’s the issue I’m thinking about.

Do you remember if you remember if you renamed your ne of the object in your scene?

Hi, if it helps? I have had the same issue - however I have been able to get the file open and displaying by tapping on the project file in the projects folder (via FIles and with Nomad open). There may also be a similar issue with files opened/imported from ICloud? - I moved files into the Nomad Projects folder to get around this).

If you managed to open the file, that’s another issue then.
Did it crash or nothing happened?

Maybe there’s a permission issue somewhere but I can’t reproduce.
I just tried to open a file in the iCloud Drive and it worked (the file was tiny though).

Hey both, sorry it took a while,
@stephomi i have just mailed you my original file. Duplicating, renaming and trying to open, moving to icloud and try to import->open or add none of these worked unfortunately. I think i have renamed objects in the scene when i initially made it yes to help differentiate of course :stuck_out_tongue: , but i never tweaked the file in any sense following the incident. When opening none appears of course and all “environment” seems to be from my last loaded file instead of the opened one. (no crash or anything like that)

@velonics thanks for your suggestion unfortunately it didn’t work for me, file is small though just 4.3mb or so

If i am honest i don’t care so much for this file i was just playing around this time, it’s just that it worries me if it happen on something more important/urgent :stuck_out_tongue:

(copy paste of my email answer)

Here’s the file fixed.
Did you name the object “beard” instead of beard (with quotation marks)?

Or did you add a special character when naming the object beard?

For the next release I’ll add a special check to handle special characters in the object name, I hope it won’t happen again.

Hi stephomi, I have the same issue, where I saved a .nom file. Took it out of the projects folder so i could uninstall and instal a new version. I did so, but it did not recognize the .nom format. So i uninstalled it, and installed an ealier version and when I open the .nom file it is an empty scene.

Is there anything i can do to recover or convert the file?

Send the file

For starter, no it’s not the “same issue”, the last post of this topic was posted when the *.nom file format wasn’t even a thing.

As for “installed an earlier version” you should never install an older version of Nomad.

  1. Always install the latest Nomad version (normally you shouldn’t even be able to install an older version…)
  2. Make sure the file has the correct extension and load it.