ChromeOS update broke the default shader

Bug reports

I updated chromeos and it broke the default shader:

There is no way to make the object white again, and all other colors have a similar tint applied, so now black is a muddy brown.

I’ve reset all the GPU settings on my chromebook, and tried to make sure all nomad settings are reset as well.

This is on an amd64/x86 chromebook, and I tried to reproduce this on my arm chromebook, but is on a different OS version. I realize you warned me the shaders might break on amd64/x86 when you made the build for x86.

I will report this issue to chromeos as well.

Oddly using the mirror tool, the secondary object has normal shading:

Ok, now I’m not certain this bug is related to chromeos. The object went back to normal shading when I merged it with a mirrored sphere, then reverted right back to it’s buggy shading.

This makes me think it’s something to do with object selection and the shader.

Never mind I just found the setting that was causing this problem … I had backface coloring enabled DOH!

1 Like

If it happens with the default sphere, it definitely is a chromeOS bug (or whatever chipset graphics it runs on).
Disabling colored backface should fix the issue (I won’t do much on my side, in any case it only affects rendering).

I think this is a user error, I think I accidentally set the color for backfaces, sorry for wasting your time.

I do have a repeatable ChromeOS on Intel crash, which doesn’t occur on ChromeOS Arm.

  1. Create a new scene
  2. Select the mask tool, mask some of the sphere
  3. Select the inflate tool

It will crash each time, do you want me to keep reporting crashes and bugs on Intel as I discover them? I keep my old Arm Chromebook nearby to test with as well.

On intel it seems 90% stable, and seems to crash sometimes when I select tools, this is the first repeatable crash I’ve gotten, most of the time it seems when I’m mousing over tools on the left hand side of the screen.