Can’t sculpt without vertex paint switching back on

Has anyone else experienced the vertex paint turning its self back on when trying to sculpt?
If I uncheck the SHOW PAINTING option in the shading panel and try to work in grey scale as soon as I touch the model the vertex paint switches back on.

I’m using a 2020 iPad with the 1.70 version of Nomad

If you have Painting active in your tool, show painting is automatically reactivated.

1 Like

Great thanks for the tip.

I was having this problem of turning off paint and use Matcap to check sculpture
When I use Smooth, it turn the paint back on.
Thanks to this post, I found where to fix this.

I say fix because feels like a problem indeed. Not so intuitive right now.

Why not make an easy access like symmetry and smooth, a button to turn on/off paint/sculpt?

1 Like

Agreed. UI stuff should be set by the user only. I think another solution would be…

When a brush is active that has painting on and “show painting” is off, there’s a little warning like the one that appears with trim/orthographic: “painting will not be applied because show painting is disabled the shading options”

1 Like

I think it’s a little buggy and that can add to the confusion. Last night I had it set off and when I used the smooth tool on my model the vertex paint switched back on. I had to repeat the steps to switch it off again. It stayed off after that.