Switching to smooth tool re-enables Show Scene Painting

Bug reports

For some reason on iOS when I go to use the smooth tool, “Show scene painting” gets re-enabled each time. As soon as I click on the object and smooth is initiated, it switches back.

iOS version 1.30

It’s not a bug but I can understand that it’s confusing.

The reason is that I redisplay the painting in case you use a tool that impacts the painting.
And typically the smoothing tool blends the painting as well.

If you go in the paint menu you can disable “color blending” on the smooth tool.
If you do that you’ll realise the paint will still be hidden.

Note: I realised the paint icon on the lower left is disabled but I should probaby enable it so that you can at least toggle blending and choose the intensity.
That way it’s more obvious if the tool is impacting the paint or not (like the other tools).

Ah, that makes sense since this is vertex based painting. My paint is just temporary so I’ll just strip it out while I work on that section.

Note that you can paint on a layer and then disable this layer if you are unusure that you want to keep the paint or not (or experiment multiple variations).