Can’t get clean edge when voxel remeshing

I have encountered this issue when I try to merge this two pieces, the eye and the head of this model, by voxel remeshing them. Normally I don’t have problems with that (nothing that a quick smoothing can’t fix) but this time no matter what I try I end up with really jagged edges.

What I’ve tried so far:

  • Trying a high poly count (over 1M vertices) by multires subdividing before the remeshing
  • The opposite, decimating every part to ~100k vertices before the remesh.
  • Remeshing high and low (with densities less than 500 the jagged edges are more noticeable) Remeshing high yields a better result, but still very bad “stitching”
  • Remeshing with “keep shap edges” both on ad off.
  • Turning smooth shading on and off

Thank you, any help will be appreciated.

EDIT: I found a solution: Using the boolean option for joining the two parts worked for me. It keeps the edges clean and it creates a single piece of geometry when exporting an stl for 3d printing. I started with both parts relatively high poly, then boolean then decimate everything. Now it’s ok. I hope it helps somebody =)

One thing I’ve noticed when voxel remeshing two parts together is that if the surface of two parts are in close parallel, I get the jagged lines.

It looks like this may be the case with your model- your eyes and eye sockets are similar around your intersection points and it seems to be having a hard time knowing which to follow.

Sel Mask your eye with the “Front facing vertex only” filter on, then extend the back side of it so your intersecting point is more perpendicular to your eye socket.

Hopefully that’s makes sense and helps.

1 Like

Hi! Maybe the smooth tool can help in this case with dynamic topology enabled.

Thank you for your reply. Yes, I tried using the Lasso Sel mask, but in the end the result was the same. I needed to create just a single piece of geometry for 3d printing (Joined parts conserve the internal geometry when exporting STL and hollowing was a mess)

I found a solution though! Just join using the Boolean option. It conserves clean edges and creates a single mesh for .stl


1 Like

Thank you! I tried that but it was really slow and I kept losing detail. The solution was joining them using the boolean menu. Thank you!

1 Like