Better default save format

The GLB format is NOT the ideal format for saving modeling data. It’s designed for run-time engines. Thus it does not properly support quads. Quads are essential for modeling and animations. While this format has an unofficial hack to get quads it seems to easily and frequently convert some of the quads to triangles which causes Nomad Sculpt to lose the sub-divisions you had originally. Any modeling changes the users make to the model increases the frequency of the quads being turned into triangles (which breaks sub-division). GLB is just not an acceptable solution for saving the models.

It’s incorrect, the “hack” that you mention is robust and has 0% failrate (if the original file was saved from Nomad of course)

The multiresolution are not saved in order to save memory.
What happens at loading is that Nomad can merge duplicate and degenerate vertex and faces. It can prevents you from reversing an object, but it only happens in some specific case (also you can check “keep topology (at import)” in the Settings.

In any case the format isn’t the issue at all.


I understand not saving the sub-division levels. However, maintaining quads is not 100%. I’ve had it split the quads quite a few times. The GLB format did not originally support quads. And still does not officially support quads that I’m aware of. There were still working on an official version for quads with the GLB.

It is 100%… as long as you save it from Nomad (the “hack” doesn’t allow any uncertainty in how it works).
If you have issues then it means you exported it from outside Nomad (in that case simply export an OBJ).

Other format are either over or under specified.

  • FBX is closed-source, an exchange format shouldn’t be closed source.
  • USD is horribly complex, the only reason Apple is using it is because there was a “Pixar” labeled on it. Supporting an exchange format that require an almost full-time dedicated developer is ridiculous.

Another option is to create your own custom format to save data. Lots of developers do that. Like Pixologic did with ZBrush.

When I import into Nomad from a GLB, it was all quads. Both in Blender and Nomad. When I saved it, it was quads. When I made changes from within Nomad and saved it, suddenly triangles appeared.

Blender glTF importer and exporter doesn’t support the quad “hack”.

Triangles don’t appear just like that, either you used dynTopo or decimation or there was a degenerate triangle, but in any case it’s not a glb issue.

Is dynTopo on by default?

No it’s disabled by default.