App closes after auto-save

Hi, nice day.
(i can’t write in english really well, so, i will try)

My nomad app closes every auto-save, i don’t know if is my divice, it’s a Xiaomi Poco F5 with 12 Ram.

I was seeing another reports about crashes, and i saw one who his app closes about the low capasity ram, when i use my app it have 8.8 ram free, so, i guess it is not my problem.

But, i realize that it crash when i draw on the sphere, i think that it is a save problem, i can see whatever into the app, but when i draw something it chash after the first brushstroke.

Maybe it is an incompatibility in the software of xiaomi, i don’t know, it’s hyperOs with android 14, i think that because Xiaomi blocks system features for external developers, something like the use of gestures in Launchers or the use of 120hz for games, i don’t know much of that but it’s what i know.

I will pay attention of this post.

Thank you for your time :).

Maybe the faq can help you a bit: FAQ | Nomad

when i draw something it chash after the first brushstroke.

Every tool or only some of them?
Try to select another “Alpha” before doing the stroke, there is a known issue that will be fixed on next release.

I tried every single brush (in the right side of the screen) , and there are just 4 brushes (or tools) that don’t crash the app:

Transform, Gizmo, Measure and view.

But i realize that Gizmo it is the only tool that modifies the sphere that don’t crash the app.
(it modify its form not like a brushstroke do)

I guess that is my phone, because i tried this app in my mother’s phone, and the app works, it’s also a xiaomi with Miui 14 and android 13, but i forgot to share that the app crashes the same way when my phone had also Miui 14 and android 13, i updated my phone two weeks ago with android 14.

I also tried what you suggest on your post, i tried:

  • " It crashes when I save or remesh my model!", but it crash with a brushstroke.

-" It crashes when I load my project!", but the app don’t save nothing.

-" It crashes when I start Nomad!", i tried it at all, but the same it don’t works, the folders are empty, and when i change the name of settings.json it reappears after i open the app again

I also tried change the “alfa” before a brush, but it also don’t work.

But nothing works.

Thanks for your patient, because it is a challenge try to write what i think in spanish to english.

How did you fix it?

i didn’t fix it yet, but…

the app works when i create a dual app of nomad app, i dont know how, but it’s the only way to the app works.