Why is there such difference in lighting between render preview and final render? Am I doing something wrong?

This is the (almost) final render of my latest project, but I’ve been noticing that there are always lighting differences between what I see in Nomad in the render preview and what the final render is. The first photo is what the render preview (pressing 4 fingers on screen at once) shows, the second photo is the render result by going to the Nomad menu and exporting the render:

As you can see, the render preview (pressing 4 fingers) is shown much more brighter. These are with the exact same settings, everything is the same, just 30 seconds apart (the time the render takes to process).

This has been also very noticeable with the “Bloom” post-process effect, where the render preview shows about 4 or 5 more times the effect than the final render, where it gets very subtle. It seems like in the render everything gets darkened, but I can’t find why.

Is there any setting I have to check/uncheck so that the exported render is more similar to the preview render? Otherwise I go crazy trying to get settings and effects and lighting right, and I have to change it everytime I want to make a turntable or a render.

Right now I’m using Nomad Sculpt 1.90 on an Android Samsung S8 Ultra tablet.

Thank you so much!

1 Like

Ok, I think I’ve found the answer. Turns out there is an option in the general settings, called “Darken unselected objects”, which I thought only affected to the viewport (so, when you’re sculpting), but it seems it also affects to the render.

Personally, I think there should be a way of disabling this, as the “render preview (pressing 4 fingers)” gets rid of this option, and the Turntable turns it off, too, so I don’t actually understand why the final render does not behave the same.

Anyway, just keep into account that this option, “darken unselected objects”, as well as “highlight selection” and “outline” options in the same settings panel, get applied to the final render, so make sure to deactivate them and unselect all objects before making the render.


Good find, thanks for sharing that answer.

1 Like