Spotlight scene size / intensity adjust?

In the HyderaBot scene, I used this huge plane as background.
Guess what happened when I changed to Spotlight? :grinning:

Intensity slider was going up to 1240 or something, but my tiny robot (same size like box primitive) was already over exposed using 15 for intensity. Impossible to adjust light properly. Took me a while to remember last fixes in change log.
light: fix spot light intensity range (small/big scene)

So I deleted the plane and the lights. Created new lights in now much smaller scene and all was fine.
I just wonder if it would be possible to add an adjustment option for scene size/intensity? Automatic adjust is wonderful like it is. A no brainer in most cases. Something people love Nomad for.
But if a scene uses big geo as background, it can get complicated when focus is just a ordinary sized object.

I don’t get the issue.

If you delete a big object in your scene (making the scene much smaller), the intensity slider range for spotlight is adjusted.

I just tried and it worked, maybe rephrase or make a quick video / screenshots?

ps: I will probably change the behavior a little bit so that the range only is adjusted, but not the intensity in case the change in scale is so big that it needs to be clamped. That way deleting a big object doesn’t trigger a change in the rendering.
So basically it would mean the intensity could exceed the slider range (until you play with sliders).

Ok maybe I understand your issue.
The background drop was still present in the scene and the range was too high?
Its a big tricky, but I have an idea, I could make the range elastic.

If you scale down the intensity, the maximum slider value will decrease. Meaning you can never have your slider at 1.0. Not sure if it’s a good idea.

Yes, backdrop still present.
I took some time to understand the relationship between big backdrop and Spotlight intensity.
Knowing the circumstances, my actual workaround is like this.
Export Backdrop and delete from scene. Adjust lights, with small backdrop dummy for shadows, import backdrop.

I tested that and it seems to work. But intensity adjustment is impossible after. The intensity is on 2 of 470.

I clearly see the issue. Making it different than full automatic will quickly lead to issues - not only for beginners.
What if there is an option like “scale exposure to selection” ? Somewhere hidden in light menu. Hidden like separate in scene menu, so average user is not disturbed, but an option left.

It is not a backdrop only task. What about geometry for shadows, which can be big like a city etc. etc.

No I’m not adding another slider/option, it can be solved differently.

1 Like