Qube Symmetry Problem

Test the file with Gizmo & Sym.

What is the issue?

See the Video.

You are confusing gizmo and symmetry, which are not linked in Nomad.

You are using custom gizmo, check “auto” on the gizmo and it will be aligned with the symmetry again (as long as you didn’t edit the symmetry through “gizmo edit” of course).

ps: the “jump gizmo” when symmetry is enabled makes more sense when the mesh are disconnected (for example a pair of eyes, as it’s annoying if the gizmo simply lies in the middle of nowhere).
It only happens when “auto” is on though, with custom pivot when can choose where the gizmo is anyway.

Sorry, it’s not easy to describe the thing because English is not my native language.
I use the Gizmo & Symmetry every day.
I think I know every trick with the symmetry/mirror PLANES by now.
Something is wrong here .
Look at the next video from 2.35 min, then you see the error.
I have restarted Nomad several times and redone the object, the error that the symmetry no longer works always comes back.

00:44 “Nothing happens”
^ I explained on my previous message why: the gizmo should be in “auto” mode

01:10 “Nothing happens”
^ That’s because “Local” is disabled (rotation is always aligned to world space axis)

01:32 * change from auto to object *
^ this is your mistake, object means you transform the whole mesh.
Thus it cannot work with symmetry!

02:45 “it’s not a correct scaling”
Works as intended (gizmo in object mode cannot support symmetry).

03:15 “the gizmo doesn’t jump”
Works as intended (gizmo in object mode cannot support symmetry)

What I can do to help a little bit:

  • hide rotation when we are in “edit” pivot mode with “local” disabled.
  • disable sym button (greyed out) if current tool is Gizmo/Transform in object mode.

I’m hesitating at removing the vertex/object/auto widgets…

Ok, now I come slowly behind it!
For me, the AUTO button had only the meaning that the gizmo/pivot (however) again automatically aligns itself to the object - to the origin……
I have not associated this AUTO button for a second with any other function.
So, when the AUTO button is off - the gizmo doesn’t jump when you turn on symmetry - OK.

I’ve used this thing thousands of times, but it hasn’t happened yet.

You really never stop learning.

Please do NOT - NOT disable/hide the SYM / Rotation if current tool is Gizmo/Transform in object mode !!!
Great things work with it !
I have understood it now, I think.
AUTO ON - SYM ON → NOW AUTO OFF + Pivot EDIT ON and place Pivot wherever you want. → The symmetry / mirror axis continues to work !

Some „bugs“ are actually features !
I miss the SHOW one MESH in the SOLO view - it is gone ! If you have 50 objects and want to see only 1 mesh and not the other 49, this was very helpful.

Danke !

Sym button is ignored if gizmo/transform is in object mode, so it doesn’t make any sense to let it enabled.
As for Rotation I’m hiding it only if “edit” is enabled.

What do you mean ? The symmetry on the PLANES works when AUTO is OFF.! In this video AUTO is OFF and the symmetry goes.

Or do you mean the AUTO/Vertex/Object function in the GIZMO menu ?

Or am I making a mistake in my thinking again?


When gizmo is in “object” mode!