Objects won’t change material

Hi, I’m having some trouble with materials. I imported a base mesh from Silo, which is a dungeons and dragons mimic - like a treasure chest monster.

For some reason, the base part and the handles don’t display materials correctly. I have a blueish metal material on the hinges and lock, but when I apply it to the handles, they look gold. When I apply a wood colour to the lid it looks fine but on the base it’s a different colour.

I tried polypainting some purple parts and on the lid they look fine, but on the base they’re muddy and barely purple.

I’m using PBR not matcaps. I tried erasing the base & handles, then reapplied the materials but they are still wrong.

They show up wrong in the viewport and the render. I’ve tried adding and removing layers. Nothing works.

Is there a per-object setting I’ve missed?

Thanks in advance for any help.

Was the base mesh already textured when you imported it?

I assigned materials in Silo to sections of both parts, but they didn’t carry over to nomad. (Possibly because of .obj format? Is there a better one to use?)

I don’t think its the format, I haven’t used Silo - try going through it’s output settings, maybe you missed something?

Thanks, I’ll look but I’ve only been having the problem in Nomad.

If it’s Nomad only, it could be a UV issue. I can’t say for certain though. UV’s from other software might not fully transition over into Nomad and might cause problems. Stephane can confirm this though when he’s available.

There is 3 ways to carry over material

  • vertex color
  • object-level material (in the mtl file for obj)
  • textures

Nomad only supports vertex color, and object color (for glb).
For obj it only supports vertex color (for obj mtl color to carry over Nomad would need to get access to the mtl which is not possible for now).

1 Like

I didn’t actually assign UV’s, only selected groups of faces and added a basic material - but that didn’t seem to come across.

I tried adding a metallic pink material to the base just to see, and it did not apply to the model at all.

I’m confused, do you mean in Nomad or in Silo?

In Nomad.

I may have fixed it, but only for the base. The only thing I remember changing was a setting: “Attach to camera’ and now the base works correctly with materials, but the handles still do not.

Hmm “attached to camera” is not the issue here.

Can you post some screenshots or video?
I’m confident there is no bug so it’s definitely a UX issue.

Double check that you are not painting on a layer that is not on top, or on the base, it’s the usual culprit.
Otherwise check that you don’t have some parts that are masked (clear mask).

Here’s the basemesh:

The material colours and smoothing groups/edge creases didn’t carry over.

This is when I had trouble with the base - the edging on the base was given the same material as the metal sections on the lid but looks like gold. The handles have the same issue and are still a problem. Also the base has the ‘gums’ painted the same purple as the lid but it barely shows.
(Edited for more info & incorrect autocorrect.)

1 Like

Personally I’m slightly confused as to what’s going on. Can you show the base mesh model as it looked when you imported it into Silo - before you added all the additional effects to it? Just to add; that is also one of the most creative chest’s I’ve ever seen. It’s a brilliant concept. That can be done in Nomad as well without the need to bring it out into other software.

I’m confused, I don’t understand your problem.

Yes, as I said previously? Objects won’t change material - #7 by stephomi

Just double check the layers in Nomad (should be at full intensity obviously). Or check that your model is not masked.
A video or more screenshots would help (one for each objects, with the whole Nomad UI, not cropped).