Nomad really struggling on Samsung Galaxy Tab S7+ with 6GB RAM

Hi there, I’ve been using Nomad for a while, but still not very confident with it - I use ZBrush as my main program so am used so super high poly counts. Anyway, I’ve been running Nomad on my Samsung Tab S7+ 6GB RAM (from 2020) and I’m noticing it really starts to struggle around 400k verts with the move brush. I feel like 400k is low enough to not cause so much lag, but alas, it is!

I’m really unsure if I’m just not using the program correctly - I’ve got multiple subdivision levels, so it’s not all just voxel meshing.

Any advice? Surely this tablet should be able to handle multi million polys? Thanks!

Yes, Nomad should handle it w/o problems. any log files?

I’m on a s7 no problems with polycounts > 20 millions. Have you tried to enable/disable Multicore sculpting in Debug? Reset Nomad to it’s default if necessary…

What’s about blender, does it have problems/does it start at all on your s7+ as well?

1 Like

Okay I enabled multi core sculpting and it seems to have helped a tiny bit (up to 2mil polys), but when i subdivide again to 8.23mil polys, the move, drag, clay (and all brushes pretty much) are all quite laggy.

As for Blender? I dont have it on my tablet, I didnt think it was possible to have as an app?

Hm, that’s strange… Do you have Matcap enabled and Post Processing disabled?
I only get lags if Post Processing is enabled. If this does not help: try to clear the cash of Nomad.

Blender is available for Linux on arm64. And as Android is basically a Linux, you can just install a distro via termux and then of course you can run Blender. But it’s not available as an App.

Thank you for all your help, I really appreciate it.

Post processing is disabled (from the Quality menu) and I have switched in the Shading menu to MatCap now.

I’ve also gone through and QuadRemeshed my model, then subdivided about 5 layers and reproject Vertex so I have a high and low poly model. That seems so have helped more with the clay brush, but the move brush lags like crazy still (model is 2.56mil polys). If I subdivide again (about 8mil polys for the single subtool), everything is laggy.

I’ve cleared Nomad’s cache too.

I’m really not familiar enough with operating systems to know how to install Blender! I’d rather keep that on my laptop anyway :slight_smile:

Thanks again for your help. Not sure why this is so frustrating. I’d rather not spend crazy amounts of money to upgrade to a different tablet, but then maybe I will need to at some point :confused:

Hm to make it clear again: your tablet is the bigger brother of mine. And as I don’t have such performance issues: before trashing your s7+ just try a factory reset. Of course: save all your data first as it will be lost.

Blender: well… the problem is the user interface. You really need a (three button) mouse + keyboard and blender does not support gesture controls. You can’t imagine how I love Nomad for that :wink:

Thanks Aszrael, I really appreciate your help! I will try to reset everything and see if that helps. Thank you again!:slight_smile: