Model always in front of Reference?

It seems that nomad is treating reference image as a plane object facing the viewport camera and sometimes “covers” the model.

Use the overlay & alpha sliders below the image selection. If the image is a PNG then it can appear to be in front of the model.

Haha, now I was checking if there is an update.
I guess it’s not handelt like a plane.
Overlay is mixing the opacity between model and background image. Is overlay on 1 it hides the model.
That’s what I know.

If it’s a png with transparency then changing alpha setting allows you to “float” the png in front of the model, with transparent background. Pretty neat.

And when you set overlay to 1 and turn on wireframe, there will be a nice effect :–)