Importing obj - colour missing

I tried importing an obj from another app into nomad. This is what I am getting. I am a bit confused why the colours are not showing up.


Which scanning app are you using? If using Scaniverse then best to shar GLB directly to Nomad. If you’re sharing OBJ then you need the MTL & JPG texture zipped together with the OBJ (I think?)

I use an app called 3D scanner. I exported the glb file but this is what I got. There were no colours.

Try Scaniverse. Also free but has much better export options. GLB to Nomad brings in UV mapped colours.
In your image, you haven’t selected PBR+UV in the rendering options, otherwise it would show UV icon at the bottom (I think?)

When I select pbr + uv, the app crashes every time.

Not sure why though. Does it do that when you select pbr + uv with no model loaded? What is your device & how big is the scan? NVM, i just saw its a really small file. Not sure whats going on there. Looks like you’re on a 2018 ipad pro maybe?

I loaded a different scan and it worked. Also I have little storage left in the iPad Pro 2019 which might be why the previous scan did not load.

Storage doesn’t matter, it’s the RAM that is important.

Or maybe the VRAM, how many textures and how big? (8k, 16k?)

You have a 2018 iPad Pro. There wasn’t a 2019 version. I got mine in 2019 also - you can check in settings > general > about :+1:t2: