I updated to 1.85 and lost all my files

I just bought Nomad, was doing some projects and got far with one, then updated and the apt kept crashing, uninstalled and checked to KEEP all the files, around 18mb, and when i started again it only showed my file from the unpurchased version, everythign else was lost, and trying to delete nomad told me there was only 3mb of files. Im on a samsung s9 fe.

There is one important rule - NEVER uninstall Nomad Sculpt.
There is no reason to uninstall.
If there is a bug, uninstalling does not help.


Gotta back those project files and brushes up

1 Like

It’s the same for every app that doesn’t have cloud management, like Procreate or Infinite Painter.
But on Android it’s a bit different, when you uninstall it asks if you want to keep the app data.
So it’s possible to uninstall the app without losing anything. One of the rare advantage of Android over iOS.

Looks like a bug from Android otherwise, Nomad never deletes its own files just like that, uninstallation is handled by Android.
I’m not sure what you mean by “showed my file from the unpurchased version”… do you have 2 nomad version installed?

Thanks for the swift replies! Well Nomad refused to open, sorry but dont remember the message but it said somethign about a bug or a crash every time I tried to open it, and reinstalling did fixed it.

What I mean by the unpurchased file is that I tried out nomad, and made a very ugly first model, loved the feeling of everything, made the purchase, and continued working and saving other projects(yes I saved both with save and save as a couple of times since I saved steps to go back to). After the reinstall, only the first ugly model was available in the files. So If one file did survived the reinstall doesnt seem to be an issue with the OS, somewhere in the process Nomad didnt saved the files I made after purchase or decided they weren’t as relevant to be kept as the “trial mode file” after uninstalling.

I clearly remember seeing all my file thumbnails including the trial mode file, so i didnt fail to save properly either. Im not doign work on it but if I was it would have been and ugly setback.

Also I did try closing Nomad and re-run it before reinstalling. But the app was already closed and just not opening. Since Im just starting I dont have any aditional assets like modified brushes that I could find missing. Also dont remember if I ever closed/shutted down the app after purchase.

Hope this helps.

1.85 was broken on many devices on Android, so I updated to 1.86.
1.85 was only live for a few hours.
It’s not the re-install that fixed it, but simply the new update.

If you can see the thumbnail then it did save the files. There is no “trial mode file”, and there is 0 difference between after or before the purchase in how files are written.

I see, I apologize I said 1.85 because that was what I saw on all youtube videos, update was done yesterday April 5th at noon and theres no available updates now so I asume I updated to the last version, I only updated once, and I understand that there might not be a diference in files, but still wanted to let you know all my files after purchase were deleted on the reinstall but not the one I did before the purchase. The first file was a single sphere and the later files did had a lot of shapes. I didnt have autosave on either. Not looking for a fix just wanted to let you know what happened, to me, if everythign was wiped clean I woudl have said ups back up next time :rofl:, but I found it weird that I chose to keep the data and only some of it remained.