Gizmo rotation problem after simple merge

I’ve run into an issue while using the input rotation feature of the Gizmo tool after using Simple Merge. I split this object (universal joint yoke) at the centre of the bolt hole in order to trim the outside of the bolt hole into a semi-circle, but after using Simple Merge to merge them back to one piece they no longer rotate in place when I input the degrees in the Gizmo tab. It remains in place if I manually rotate using the Gizmo Widget, but I find that’s more tedious and less accurate that inputting the number of degrees. I have the same issue with using the Transform Tool and when I Voxel Merge rather than Simple Merge. Is this common with merged objects or is there a setting that can change this? Thanks for any advice!

You mesh local coordinate is not centered at the origin, you can use “move to origin” then move translates bake where it belongs (do not bake it)

But you should use manual rotation instead, with full control on where the pivot is.
For 90°, simply use the snap angle tool on the left, it’s precise for rotation.

Thanks a lot for getting back to me! Sorry, but I still don’t understand how to re-centre the mesh. I tried Move To Origin under the Gizmo tab, but the object still doesn’t rotate on the centre point and I’m not sure what you mean by “ then move translates bake where it belongs”. I also tried the Reset Mesh Centre under the Symmetry tab, but that also doesn’t seem to change anything. Thanks for recommending the snap feature, I think that will work well, but I think it’s still important for me to know how to re-centre the mesh. Thanks again!

Hit bake after merge origin.

Awesome, thank you so much!