Recenter Gizmo to zero rotations without affecting object

I’m sure this has probably been answered but I cannot find it. In most 3d programs if you rotate an object you can reset the gizmo itself so it zeroes out to 0 degrees rotation on all axis without affecting the object. The example shows what I want to do. I can use the pivot tool to approximately re-rotate the gizmo but I really want to accurately reset the gizmo to 0 rotations. I tried the reset option in the gizmo tool but it resets the object as well. I’m sure I’m missing something very basic but can’t find it. Any help is appreciated!
Gizmo

Like this?

image

Actually no. I was hoping to be able to reset the objects local axis to zero rotations.This is pretty simple in Zbrush but perhaps that feature is not in Nomad as of now. I appreciate the response however

You can reset the pivot, then it should be straight again.
Or you can use the World option in the sidebar.

Both comes close but what you want, I believe it can’t be done at the moment. “World” (or “align” in the web demo) is only temporary, and “reset” moves the pivot to the bounding box center.

If that’s ok “reset” might work for you. If the object is rotated, try “bake” before reset

Align is there for that, it reset the gizmo rotation as in “most 3d programs”.

Zbrush is not “most 3d programs”, actually it doesn’t even have hierarchy and the objects probably don’t even have transforms…
Basically using Nomad like zbrush would mean to only use the gizmo in “vertex mode”.
In that case Pivot->Reset would always reset to identity.


Otherwise you need to:

  • make sure the object has no parent
  • bake the matrix

It’s a bad solution though, baking should be avoid most of the time.

I think this might do what you want: 1) rotate object desired amount 2) go to gizmo settings and click “bake” (this will also bake any scaling and translation, but I don’t think that can be helped) 3) click pivot on left hand column (make sure “world” is not also selected) 3) click reset. The local pivot should now return to vertical, the object won’t move. The key step is baking the gizmo settings after the first rotation, I think.
Hope this was what you wanted.
(Just read Ray’s post - he’s given the same answer)