Create morph for Daz3D

Do any of you by any chance use the app to create morphs for Daz3D (Genesis 8)? I use Daz regularly and I bought the app to be able to create morphs, as an alternative to Blender. Unfortunately, however, when I import the morph (obj) in Daz, I get an error (geometry did not match). I don’t know where I’m wrong …

1 Like

I just tried this and got the same warning on vert order. In this case, I only used the move tool, which I felt would be the safest for maintaining vert order. Yet it seems not. Is there a way to conserve the vert order? Settings? Tools that should be used? I figured nothing that would cut or add mesh such as voxel. It would be great to be able to create morphs on my iPad.

Thanks.

Tried a further test. Imported the Daz model obj and exported without any modification and got the same vert order warning. Any help would be appreciated.

Thanks Chris! In settings there is “Keep topology (at import)” that should maintain vertex order in import process. I tried to check it but I have no luck. I suppose that it should be a setting for obj export too for maintain vertex order

Keep topology at import should work.

Wouldn’t work because the reordering happens at loading, not at exporting.
You should check the option and reload your model, then export in obj all the poses.

Normally if you want to expoert the morphs, you should export glTF with layers. But I suppose daz doesn’t support glTF… if it supports morph in FBX you clan try to export in glTF and then convert to FBX (for example in blender).
That way no need to export layers one by one.

I’ve tried with keep topology but I have the same problem. It seems that vertex order changes anyway.

Would also like to see this fixed.

DAZ is a little bit old fashioned and for DAZ OBJ is the format we normally use :roll_eyes:

Keep topology does keep the vertex order, so either you are doing it wrong, or something in wrong (or unspecified) in DAZ.

so if pretty much all sculpting apps can export objs that work with DAZ, my main suspect would be the app that can’t do it :wink:

Maybe this will help.

I created a simple cube in Blender. If I export the cube in Blender as an obj the file looks like this:

# Blender v3.0.0 OBJ File: ''
# www.blender.org
mtllib box.mtl
o Cube
v 1.000000 1.000000 -1.000000
v 1.000000 -1.000000 -1.000000
v 1.000000 1.000000 1.000000
v 1.000000 -1.000000 1.000000
v -1.000000 1.000000 -1.000000
v -1.000000 -1.000000 -1.000000
v -1.000000 1.000000 1.000000
v -1.000000 -1.000000 1.000000
vt 0.875000 0.500000
vt 0.625000 0.750000
vt 0.625000 0.500000
vt 0.375000 1.000000
vt 0.375000 0.750000
vt 0.625000 0.000000
vt 0.375000 0.250000
vt 0.375000 0.000000
vt 0.375000 0.500000
vt 0.125000 0.750000
vt 0.125000 0.500000
vt 0.625000 0.250000
vt 0.875000 0.750000
vt 0.625000 1.000000
vn 0.0000 1.0000 0.0000
vn 0.0000 0.0000 1.0000
vn -1.0000 0.0000 0.0000
vn 0.0000 -1.0000 0.0000
vn 1.0000 0.0000 0.0000
vn 0.0000 0.0000 -1.0000
usemtl Material
s off
f 5/1/1 3/2/1 1/3/1
f 3/2/2 8/4/2 4/5/2
f 7/6/3 6/7/3 8/8/3
f 2/9/4 8/10/4 6/11/4
f 1/3/5 4/5/5 2/9/5
f 5/12/6 2/9/6 6/7/6
f 5/1/1 7/13/1 3/2/1
f 3/2/2 7/14/2 8/4/2
f 7/6/3 5/12/3 6/7/3
f 2/9/4 4/5/4 8/10/4
f 1/3/5 3/2/5 4/5/5
f 5/12/6 1/3/6 2/9/6

Than I import the same cube in Nomand with Keep Vertex Order enabled and export it unchanged as an obj.

The same cube from Nomand looks like this:

# Exported from Nomad Sculpt
o Cube
usemtl mat0_Cube
v 1 1 -1
v 1 -1 -1
v 1 1 1
v 1 -1 1
v -1 1 -1
v -1 -1 -1
v -1 1 1
v -1 -1 1
vt 0.625 0.5
vt 0.375 0.5
vt 0.625 0.75
vt 0.375 0.75
vt 0.875 0.5
vt 0.375 0.25
vt 0.625 0
vt 0.375 1
vt 0.625 0.25
vt 0.125 0.5
vt 0.875 0.75
vt 0.625 1
vt 0.375 0
vt 0.125 0.75
s 0
f 5/5 3/3 1/1
f 3/3 8/8 4/4
f 7/7 6/6 8/13
f 2/2 8/14 6/10
f 1/1 4/4 2/2
f 5/9 2/2 6/6
f 5/5 7/11 3/3
f 3/3 7/12 8/8
f 7/7 5/9 6/6
f 2/2 4/4 8/14
f 1/1 3/3 4/4
f 5/9 1/1 2/2

I can’t really read obj files in plain text, but looks pretty different for me.

Edit: As a new forum member I cant post than three times in a thread…
So here’s my answer:

@stephomi

Okay, I read the wiki article about the WAVE OBJ format. Your right, vertex order should be the same for both objs.

I did used the same cube in DAZ and imported the nomad cube export as a DAZ morph.
Didn’t got the vertix order error which @crispalomino mentioned.

As soon if I find the time I try also to verify it with a DAZ Genesis 8 figure.

About zBrush. I don’t have/use zBrush, but I know that a lot of artists are doing with zBrush DAZ morphs.

Discard the UV, only the position are kept in order.
(if you need them, simply export the base and morphs all in one go from Nomad, doesn’t matter if you have “keep topology” in that scenario).

ZBrush doesn’t keep the UV order either (at least when I tried).
Same for Blender, it only keeps position order (even though I check keep vertex order on both import and export).

I simply took the base cube from nomad with UV on it.

But there is something wrong. In my opinion, the order of the vertices is somewhat changed. I exported the character from Daz, in obj format, as I always do, imported into Nomad with the Keep Topology (at import) function enabled, exported as obj (without modifying it) and re-imported back to Daz, I get the "geometry did not match " error. Same procedure, with Blender does not give errors.

Export the base from Nomad as well.

What settings should I use? These are the ones I used to export the obj

Hey,

I’ve would have answered earlier, but until now I was limited to three posts/topic.

However, I figured out how to use Nomand Sculp to create DAZ morphs.

  1. Load the dev figure of a Genesis figure in DAZ (you may also use a normal figure, but then don’t forget delete eye brows and other attachments)
    DAZ Figure

  2. Set the resolution level to Basic

  3. Export the figure as an obj this setting (and make sure that the figure is the only visible element in DAZ)

  4. In Nomand Sculp make sure that you "Keep topology (at import) activated. This setting may get lost after the Nomand Sculpt restarts.

  5. Export your figure as an obj

  6. Import it with the DAZ Morph Loader Pro with this settings:

Done, works for me.

@stephomi
I found something wired, if I export the DAZ figure with “Write Groups” (see screenshot step 3)
than the figure is broken in Nomand. I got hunderts of sepearte objects (and the same name), instead of one object.
Not sure if this is intended.

I did a test this morning in a bit of a rush and it seems to work. I tried to create a morph and there were no errors. Probably the problem was related to the export parameters from Daz

Thanks, Steph, and everyone, will try this.

Edit, since newbie: Worked perfectly, thank you. Figured it might be settings. I normally make my morphs in ZB with no issue, so was using the exported base I always use, but settings were slightly different. Write groups and materials are normally enabled.