Bug with multiresolution optimization

Steps to reproduce:

  1. Create lower resolution of high-res mesh with Multiresolution -> Reverse
  2. Switch back to high resolution
  3. Rotate/pan camera

Looks like something is wonky when it tries showing the lower-res version during camera move.

(Also, I’m getting a crash when trying to make a lower-res multiresolution level in a copy of this file. Weirdly, this file lets me make a lower-res version. If I make a copy of it with Save As, then try doing a Reverse on the copy, it crashes.)

Ah this is bad.

I tried with a simple mesh (sphere) but I couldn’t reproduce.
Do you have a simple way to reproduce the bug?
Otherwise you can simply send me the file at stephaneginier@gmail.com.

I can’t seem to reproduce with other models, either. Even ones created in the previous version. Looking at how the screwy model is structured, maybe something to do with the painted vertices? Is there a way to clear all vertex paint info?

Some more information on the crashing: the crashing on reverse issue appears to be when I have one mesh open, then open another and do the reverse operation (so, I had the original file open, created/opened a copy, then tried the Reverse, and it crashed).

If I have a copy of the project open, force quit the app, then reopen so the copy is the first thing opened, I’m able to do a multires Reverse, and the rendering issue shows up there, too. I’ll email you a dropbox link for the file.

It can’t be the painting since the reverse is working exclusively with the topology information (vertices and quads).

I can easily reproduce the issue with your file so I’ll be able to fix it, thanks!

Awesome! Happy to help. :slight_smile:

I managed to fix the bug.

Thanks for the file, nice model!

The issue was that app was trying to render the lower resolution when it shouldn’t have to.
Depending on the topology, sometimes I can’t reuse the lower resolution, and it was the case here.

Instead of reverting to the old behaviour I manage to fix the whole thing, so now it should always be possible to reuse lower resolution.
It was a limitation that I had for probably more than 5 years :slight_smile: (from sculptgl).

Concerning the crash, I suspect you simply ran out of memory.
You can check the “free” ram.

Hey thanks! I had a lot of fun making it. Nomad is a dream to work with. It’s obvious you’ve put a lot of thought into the UI.

And yeah, I figured it was a RAM issue. I’ve run into a couple of other similar crashes. How hard would it be to catch that kind of memory error and fail the operation instead of crashing entirely?

I don’t think you will find many softwares that gracefully recovers from out-of-memory issue.
It’s a bit of a pain.

Also the “free/available” memory is typically not something that you can trust blindly.
On iOS it seems relatively reliable but on Android I couldn’t get the information clearly.

1.34 should be live with the fix!

Oh nice!

I don’t suppose it’ll fix this model that blew up after a crash? :weary:

/edit: it did not, but I’m guessing this is the other multires bug that got fixed.

Ah well. I want that happy with it anyway. Good excuse to start it over.

Yep corrupted files are lost for good.
Actually that’s the reason why I made this quick release, broken saves is the worst thing that can happen.

1 Like