Auto gizmo mode for repeaters confusing

(beta feedback) New repeaters being set up in gizmo mode when the gizmo was the active tool I find confusing. The interactive bits of the repeaters like the curve should always appear after adding a repeater the to the scene, no matter what tool was active.

I think it would be ok/better having to reactivate the gizmo.

Have you already tried the Gizmo settings in the ADD Primitive menu?

Yes I’m continually impressed by the new stuff added. But “select gizmo” doesn’t seem to have an effect on repeaters.

Yes I can automatically switch off gizmo toggle when adding a primitive.
Similarly I should probably force enable the option when you select the gizmo( and a primitive/repeater is already selected).

And if you only select mesh/primitive/repeater I do nothing.

Thanks. The less the UI is dependent on the “before” state, the better I think.

both make sense

I wonder whether things could be even simplified more (with UI showing 3 gizmo buttons left/top/right sometimes)