Antialiasing render glitch? Halo of black pixels around scene objects

Hi, first off amazing app!

I’m seeing what looks like an antialiasing glitch on the Air 4, it looks to me like any pixels I’d expect to be antialiased are coming out as a couple of pixels outline that’s fully black. It could also be depth related as it’s slightly lessened where objects intersect.


Any idea what this could be?


1 Like

A bit of extra info, it only applies to PBR mode.

It’s a known I received many feedbacks on this particular issue, for example this one
It only happens on the Air 4 (that I don’t have).

Can you confirm the bug is still happening when you have:

  • smoothing shading on (Settings menu)
  • no lights/shadows
  • try disabling “Buffer reuse” in the Interface menu

Otherwise rebooting completely the iPad usually fix the issue from what I heard, but only temporarily.

Hi, thanks for the quick reply.

Yes I can check these:

  • Smooth shading - occurs both on and off but in different areas, where there are harder edges or a bigger angle between adjacent normals in flat shaded mode
  • Lights/shadows - these do not seem to affect the issue in any way, it’s still present
  • Buffer reuse - same, the issue is still present and does not change
  • Reboot - correct, it’s not present after a reboot. Maybe it only occurs after the iPad has put the app to sleep? I’ll have a mess about, see if I can figure anything out.

Let me know if there’s anything else you want me to try, thanks!

Can you replicate the bug in a consistent manner?
(thinking about opening Nomad and quickly switching on/off the iPad, or something).

  • is curvature postprocess working fine with Matcap?
  • is SSAO postprocess working fine with Matcap?
  • Does exiting and re-running Nomad fix the issue? (not just moving it to the background)

I’ll try something for Nomad 1.46 but I’m starting to run out of idea, so I’m thinking about buying the Air 4 just to fix this bug.

You could always use it for the giveaway you mentioned after you’re done lol

1 Like

Hi Stéphane, I’ve tried a load of things to get a solid repro case but haven’t found anything so far, except that it’s okay after a reboot - which isn’t a lot of use! I’ll try the additional steps you mention whenever I next spot the glitch.

I like Justin’s suggestion - mine was going to be order an Air 4 from Amazon, fix the bug and then return it. Shhhh… :slight_smile:

Costco’s return policy is pretty great. :man_shrugging:

1 Like

I just got an Air 4 and had this same issue.

I tried force-closing the app and rebooting the iPad, but neither of those things helped. My third idea was to re-open my project, but it was my only one. So, I created a new project, and the issue was gone. I haven’t had the issue show back up yet, but I will see if I can do the same to fix it the next time.

My black pixels came back again. Creating a project and reopening mine was not enough, though. You have to switch to Matcap, save, then make a new project. Then reopen your project, and go back to PBR, and no more black pixels.

See Nomad Change Log - #22 by stephomi, the issue will be fixed on 1.48

1 Like

Awesome news and thanks! What was it, just out of game developer curiosity?

A trilinear look-up texture for PBR (RG16F LUT for DFG term).
Now I simply use it as a bilinear texture and it works fine.
I guess there was an issue with the mipmaps, not sure why the bug were occurring randomly though.

1 Like

Or only with the Air, different GPU gremlins I guess. Thanks again for sorting it!

absolutely, I also like Costco’s return policy pretty much. I read through the Costco return policy. AS mentioned in there. Costco also offers 90 days of time frame to return some products with some exceptions. It describes in detail Costco’s return and refund policy on different products.