1.41 spot light problem

I have just made the update and I noticed the spot works badly, that is to say that on the one hand the maximum intensity with a softness at zero still gives a dim light and is more it seems to me that with the metal materials it remains very dark. but I also noticed that it depends on my scene, I don’t know if it is related to the size of the scene but in some of my projects the spots don’t give any effects as if there were none and in others project is
more or less good.

Screenshots with a simple setup please.
So that we can compare with other 3d softwares (ideally you should always compare with other tools, like blender, sketchfab, unity, unreal, etc).

As expected? Softness simply makes the spot border more or less smooth.

Probably normal if the metal has a low roughness.
It’s a ponctual light so there’s not much to reflect.
It’s like that for every kind of lights except area lights (not present in Nomad at the moment).

Ponctual lights depends on the size, it’s different than the infinite directional light. You should adjust the intensity.

Dans 5 Minutes chef :wink:

I edited my first answer.

I’m don’t think there is are any issues.

Except on the UI side, sometimes the panel closes when it should not, which is a bit annoying.

Just Made 3 min tests but work as expected. Thank you very much!!!
@Costorella_Stefano metals are related to environment when roughness is 0 and environment intensity as well, you’ll see only reflection of light source in metal, a tiny white dot. Rest is black. No mater if directional or spot :wink:

So here in the first scene I have a green spot with maximum intensity and zero softness. however the light is not very bright (I know that with the environment it can be distorted but it is something else). on my human model (pbr always) I voluntarily set the exposure of the environment to zero and although the spot is almost glued to the model, well we see nothing, the material has a roughness of 1 but even with some other material settings it’s the same. so I wonder if it’s not the size of the world that would be the problem.

I can confirm there is an issue with the intensity slider for the spot light.
The slider is directly linked to the scene world, but the range should be much higher.

Until it’s fixed for the next release (probably next week), you can scale down your scene.
Select all objects and use the gizmo to quickly scale down everything.

1 Like

We are a great bunch of debuggers lol.

@stephomi New bug detetected with spots, when i duplicate spot the duplicate one is présent but icône is invisible just gizmo is visible. Same with directional :frowning:

There seems to be the clone function broken. No prob. with add light function.

Yes it’s a stupid issue, will be fixed as well.