Using layer to rotate obj

The layer tool worked perfectly for moving or scaling the object but for rotating the object The result is (rotating+ scaling ) like the video below

Rotating obj with layer

I try it on iPhone and iPad
I’m using nomad sculpt 1.32

That’s as expected, layers only encode a linear offset, that’s why you get this effect.

You will have the same issue on other softwares that supports layers as well.

1 Like

Oh I see, it’s my first time using layers that’s why I wasn’t aware of it.


It looks like the layers are just linear blendshapes under the hood which would explain the behavior. It could be solved with a different interpolation type (multiquadratic or rotational)… but for 99% of the cases it’s not needed…

1 Like

I’ve never heard of « non linear blend shape ».

The problem here is not the interpolation but the blendshape itself which is mostly 2 positions, so you can’t really do much with only 2 absolutes positions.

The correct way to handle the issue above is simply not using blendshape, but simply keyframe transform.

Also note that by default most gizmo operation are not recorded by the layer since it operates directly on the mesh transform.
You can change this behavior in the gizmo menu by selecting the method with “vertex”. It must have been the case in the video above.

Now that I think about it, I could add one transform per layer so that I could record these changes.
However I would need to dig glTF animation system to export correctly the animation keyframe, so it’s not high priority.

1 Like

In XSI the was an option for a cardinal spline transition if you defined an third (in-between) blendshape. But for a sculpting software, this probably wouldn’t make much sense.

A bit off topic but I found that when sculpting on a layer at 50%, it modified the base shape as well. I think it is more intuitive to apply only 50% of the full result then and not modify the base (unless there’s a technical reason to do it that way).

With 3 values it would work indeed.

Yes there’s technica reason behind, the offsets are not handled the same way as the painting.
Due to memory/perf optimisation but also code simplicity.

However, what I can do easily is simpy force the intensity to 1.0 when you start sculpting.

Setting to 100% is what Zbrush does too, but actually of these 2 options I think it’s better like you do it (adds some new workflows possibilities).

Another option if possible is to keep the intensity at eg. 40%, but sculpt full, and then recompute the result as the new 40%. So you could overdrive the sculpt by setting it to 100% later.

Ah that’s exactly what I was experimenting, the brush stroke acts as regular and at the end it’s scale down.

I’ll probably keep this variant, the base mesh won’t be impacted that way.

sounds good :grinning: