Problems with getting alphas into Nomad

Okay, I’m getting extremely frustrated trying to get my own alphas into Nomad for sculpting. I need to know if there is a file requirement - png, jpg or psd? Is there a maximum or minimum size? I have tried png’s, jpg’s and (having just thought about it :slight_smile: ) psd’s next. I have used black on white and white on black, but they always import into Nomad as either a white or black square. I am creating them in Procreate and saving one layer (no background), then saving into the Alpha folder in Nomad. Both jpg and png will import (I can see their file name) but, as I said, only appear to be white or black squares.

SOLVED - Leaving this here for anyone else who encounters the same problem - A PSD file worked for me.

PNG and JPG work fine.

I just tried in procreate and it worked fine with or without the background, black on white or the opposite.
However for JPG you need to enable the background because JPG doesn’t support transparency (Procreate decide to write white instead of transparency but that’s arbitrary).

The best way is to paint in white on black background.

Note that psd is not supported perfectly.
Also Nomad doesn’t resize the alphas so it might be a good idea to resize the alpha if brush performance suffers.
Other than that, there’s no limit.

Note 2: the official way is to use the import button for alphas.
Dropping them works as well but you need to quit and relaunch the app.

Thanks. Strange that I couldn’t get png or jpg to work, only PSD. With regards to the resizing within Nomad I can tell you that next to each of the PSD files in the Alpha folder there is now a smaller sized file with the same name. For example, the latest one I just imported was a 3.7mb PSD file. Next to it is a 1mb of unknown type. I assumed that Nomad created these for use in the programme?

Yes if the file is not a jpg or png it is converted.

Bringing this up because now I’m having the exact opposite problem!! I decided to import some Zbrush alphas. However, after I hit the + or Import button I navigate to my Files and if I click on a PSD file the picker window closes and returns to Nomad without anything happening (even if I click in the row of alphas). But, if I do the exact same thing and click on a PNG file (and then click on a blank space in the row of alphas) it will appear every time.

And to add another HOWEVER - if I create a PSD from Procreate it DOES import into Nomad no problem.

Is there maybe an issue with the PSD file itself with regards to how/where it was created?

Yes PSD is not supported officially, but some simpel PSD can work though.

All JPG/PNG should work though, through the import button, is it not the case? (make sure the files got a name that doesn’t exist already)

Thanks. I did get PNG’s working, it’s the PSD’s that do not. Or, I should say, not all PSD’s. No need to reply, I figure there is just an issue with what programme was used to create the PSD since ones created in Procreate DO work.

If I’m making my own alphas in photoshop, what specs are best?
Width/Height in pixels?–
Resolution? –
8 bit/ 16bit /32 bit? –

For resolution: It depends on many thing, mostly the max polygon you want to use the alpha and the amount of detail on your alpha.
At the moment Nomad doesn’t rescale the alpha. And the alpha doesn’t have to be square.
Big images might slow down sculpting though.

For precision, at the moment Nomad forces the depth to 8 bit, so it’s useless to use 16/32 bit.
For next release I’ll add 16 bit support though.

1 Like

I’ll stick with 8 bit.

If you make changes to the alpha system maybe scale and depth of the Stamp tool can be a separate adjustment.
Unless I’m doing it wrong the larger I scale an alpha the deeper it gets.

Late reply, but you can adjust the brush curve settings that do help in that regard. Not sure this was an option when you first posted this.

I use nomad on Android. I recently put psd alphas in the nomad alphas folder. They weren’t converted, instead nomad put them in a folder called “can_be_deleted”

Same behavior happens on the iOS side. Started examining how Nomad works with alphas a couple days ago. Started by dropping a few PSDs from the MacBook (ZBrush folder) over to the iPad’s alphas folder. With v1.65 running, went into the app, tried to add them to the fly-out side palette, but they only appeared as white square thumbnails. A few moments later when I revisited the tablet, I found all the PSDs sitting in that can be deleted folder.

Next day, I converted the PSDs to JPG on the MacBook and tossed the resulting files to the iPad alphas folder once more. When Nomad was relaunched, some sort of brief message displayed (possibly about updating the alpha thumbnails). Went to check the fly-out palette and the alphas were all properly displayed.

1 Like

@dara @CarterTG

I never tried psd as they are officially not supported. Never had any issues with jpg or png though.

1 Like

The point is that the large majority of users initially looking into this don’t know that — there’s no obvious clue on what is and isn’t supported. (ie, circled question mark with pop-up help blurb)

…even an old-school readme file installed by default in the alphas folder would’ve helped tremendously.

1 Like

That’s true.
Worlking with ipads since V2 I’ve learned not to expect anything regarding compatibilty and being happy about those few formats working with no probs. A little questionmark with info beide the plus sign would be cool though.

Okay thanks. What app did you use to convert the PSD files?

Since the my PSDs belonged to ZBrush on the MacBook Pro, I just fired up Affinity Photo, converted there, and using MacOSs’ Universal Control, group dragged the JPGs over to the iPad Files folder.

Without the MacBook Pro, I likely would’ve fired up the iPad version of Affinity Photo and do the converting there. Would’ve been slightly more tedious working on one image at a time.

At some later point when there’s more time, I intend on going back into Affinity Photo & make a dedicated template. The template goal would be to conform future alphas to a square shape and set it up to intentionally add a blurred vignette blurring it out to 100% black at the edges. Occasionally, I’ll see something that LOOKs like a good texturing alpha candidate, but the image goes all the way to the edges. In my experience with alphas in ZBrush, this can result in bad texturing behavior. With a properly made template, all manner of images can be dropped in and the proper vignetting will be applied.

1 Like