Not sure what this glitch is?

I noticed that when I import in an OBJ from ZBrush… and I go to add a new primitive from Nomad… I can scale and use gizmo just fine… but if I want to navigate the scene to say align a sphere to create an eyeball better it starts visually glitching out. It’s hard to explain… I use my pencil or finger to navigate around the scene and the models start slicing and disappearing. Rotating towards center of scene glitches worse while navigating around perimeter of scene seems to be less glitchy. Sometimes the model flips… sometimes it pulls from itself in a symmetrical way but your seeing the underside of it to the left and it upright on right but also flashing fast like flashes/impulses… somethings not right. I screen captured video - but you can’t post videos right?

Now if I already drop in spheres for eyes in ZBrush and import all parts back into Nomad than no glitching at all.

I know there will be times I will need to bring a model created in another program and also also add new primitives from Nomad to build out more complex compound forms within Nomad. I also remembered this happened with my Panthro model when I brought in new Nomad spheres for eyes. It worked out, but freaked me out a little. But then I couldn’t replicate and felt OK — Till it started again and constant with this model…

No big deal - I just brought the parts in from ZBrush - but after much trail and error. I just wanted to share what I encountered. Also figured it might connect to someone on what could be the problem?


Just fine when I bring in and import the head and both spheres from ZBrush…

What I’m seeing from your images is a near clipping plane issue, where parts that are too close to the camera are cut off. From what you described, I think what’s happening is that the camera is not focused on your model after you add the sphere, and as you navigate around, you get too close. To avoid that, make sure to tap on the original object after adding the eyes so that you can zoom in on it instead of having to pan. If you have a scene where the view is already messed up, see if the reset view button fixes it.

Yes it’s a rendering issue (clipping plane), it should never happen.

I could easily fix this if I got a reproducible scenario.
Ideally you could send the file and the exact steps to reproduce the issue.

Stephomi how can I get you this rough crow model file so you can recreate the scenario? No problem - the design is mine and I’m only just starting to model. This is a good time if any to share with you. You just need that crow head, right? It’s just an OBJ. There’s no other file I’m bringing in except a Nomad primitive sphere. Thanks so much and glad to help! If it’s something I can avoid would love to learn how.

Andrew thank you for helping me wrap my head around this. I appreciate your help and feedback. I’ve never encountered what you described before. Was this something I did on my side? I’ll try your suggestions this morning? So is this something that happens easily? After so many hours in Nomad it just started happening - I didn’t know what I did differently??? I thought I messed something up… lol

Yep I just need the file and the exact steps to reproduce the bug.
You can send me the file at

Also tried Andrew’s suggestions and here is also what I found… my world origin is off? But I have no idea and getting it back is not working? I tried double tapping the crow head after bringing in the sphere and the clipping thing stopped… I tried not clicking on the head and the clipping started again - so you were right on that note? Here is also what’s interesting. I did reset the world coordinates back in ZBrush for this crude early sculpt and prepared this OBJ as light and simple as possible to go into Nomad. I imported a the file like normal and it opens up just fine. I then go to adding another sphere primitive and validate. If I double click on the crow head after importing a sphere no clipping issue. When I go to symmetry window and turn on symmetry it shows it going down the crows head. Now If I ask it to reset world origin… it moves it way off to the left. If I pick local it’s fine and back on center on the crows head. If I click on mirroring the sphere so I have two eyeballs it shoots it way off world center. I’ve done this technique before and it works fine. I even tried this quick method right now with all fresh primitives and it works just fine. It’s obviously the crow head model but I’m not getting any errors anywhere and not sure how to fix or approach Stephomi.

You can recenter the model by selecting the gizmo and in the tool settings click on “move origin”.
Also being in orthographics vs perspective might change the outcome.

But once again, if I don’t have the model and the steps to reproduce I won’t be able to investigate.
I already changed a few things concerning the clipping thing and it’s possible it’s alredy fixed on my dev version.

Emailing now Stephomi… I just wanted to give the whole big picture

I will take a look.

Here another similar issue
I know there is an issue with orthographic mode, but I’m unsure if your issue is similar.

I will check that out… Thanks for sharing. Email with OBJ just sent!

Just checked out the video Stephomi - YES! That’s exactly the way it looks when it’s glitching. I have my screen capture video if you want me to send it? But yeah that’s exactly what I’m experiencing.

So I can already see 2 things:

  • the crow head is not cented in the world origin, there is indeed an issue when loading a file: the symmetry plane is local by default but the UI shows “World”, I’ll fix that. On next release when you’ll import the crow, the symmetry plane will indeed be off-centered.

  • I can’t reproduce the issue just by loading the crow on a new scene.
    I think the issue is simply that you had orthographic view with an off-centered pivot point.
    So in the end I didn’t need the crow :). I’ll fix the ortho-pivot as well for the next release.

Until then, I suggest to use the “double-tap on background” more regularly, especially with orthographic mode.

Thanks Stephomi - this is so great. Appreciate your direct help

Ok - I think I nailed the solution based on gathering everyone’s info…


  • Import OBJ
  • Turn off Orthographic view / turn on Perspective
  • (symmetry) Go to World Center Origin - click button
  • GIZMO / Transform: Click move origin
  • Model is re-centered in Nomad World origin
  • No clipping rendering issues / imported primitives symmetry just right when coming in

The problem was it was saying it was symmetrical or assumed zero’d out in world coordinates and it wasn’t the case when it was imported - I think that’s what you were saying a Stephomi? The weird part is how the OBJ got this way? It was centered in ZBrush? But this seems to fix it right up… thank you so much!

This process is dependable with no issue so far… I’ve replicated it multiple times with the same results.

There’s a simpler scenario:

  • turn on orthographic
  • translate the object with the gizmo
  • rotate the camera

The core problem is how I handle orthographic camera, until I fix the issue you can use perspective mode.

I can confirm at 100% the crow is not centered :slight_smile:

1 Like

Thank you so much Stephomi — I totally believe you on It not being centered… it’s just weird it’s showing it in ZBrush that way? Something must have happened - I would have been lost without your help - thank you.